Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have installed ubuntu and now I want to install flex. It asks for password but when I type my password, it asks me the password for root.

When I enter the password which I had specified during installation, it says, "Your authentication attempt was unsuccessful. Please try again."

Whether the password for root is locked or is it something else? The passwords I entered were correct.

I have also tried sudo su but it says, "Unable to change to sudoers gid :operation not permitted."

I have tried su also but when I enter the password it says, "Authentication failure".

Please help me out. I thought that maybe this is because the root user is locked by default. If so, how to recover from it? And if something else is the issue then what to do?

share|improve this question

closed as off-topic by guntbert, Braiam, Eric Carvalho, Seth, Lucio Dec 1 '13 at 4:06

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This describes a problem that can't be reproduced that seemingly went away on its own or was only relevant to a very specific period of time. It's off-topic as it's unlikely to help future readers." – guntbert, Braiam, Eric Carvalho, Seth
If this question can be reworded to fit the rules in the help center, please edit the question.

In a terminal, sudo su is not working either? – grimpitch May 10 '13 at 2:26
What command are you trying to run? Did you try running the command with sudo instead of becoming root with su then running the command? – notkevin May 10 '13 at 2:34
sudo was also giving problem. i have re installed with diff. wubi.i thought problem was with wubi of 13.04 .now every thing works fine. thanks.i got solution on – usmangani May 10 '13 at 14:57
For voters: see OP's comment on 1st answer. – guntbert Nov 29 '13 at 20:48

The command you're looking for is sudo -s. You can also accomplish the same thing with sudo bash

su and sudo su doesn't work on Ubuntu for security reasons. It fails because the root user does not have a password, and those operations are you attempting to "log in" as user root

share|improve this answer
sudo su sure does work, it's just a bit silly to run sudo to run su, when you can just run sudo -s if you want a shell as root. – psusi May 10 '13 at 3:48
I found the answer. the problem was with wubi.i have re installed with wubi12.04. and working fine. – usmangani May 10 '13 at 14:54
@usmangani just a tip, don't use wubi. It is not supported any more and causes more problems than it solves. Just install Ubuntu the regular way for the best experience (and more speed). – mniess Nov 29 '13 at 15:49



Then logged in, And run the following command

 sudo chown -R user:user /home/user/.*

Where user:user is your user name, example qasim:qasim


getting setgid:Operation not permitted error while running 'su' command - Ubuntu 12.04

share|improve this answer
Ctrl+Alt+F1 got me to a console login. I wasn't able to log into the GUI using root, and su/sudo wouldn't work from the guest login. – Brain2000 Sep 19 '14 at 17:36

You can add a "#" before

/usr/bin/sudo Ux, 



and i also removed the "#" from

#include <tunables/global>
#include <abstractions/lightdm>
#include <abstractions/lightdm_chromium-browser>

in /etc/apparmor.d/lightdm-guest-session

but i don't know if all of this is necessary

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.