Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.


I cannot add any applet to any (top or bottom) panel, cannot delete any panel nor create a new panel. When I right-click on the panel the only options available are: Properties, Help or About panels.

[I cannot post an image because of spam prevention, so I'll do my best]
I can see when I right-click (bold means clickable):

  • Add to panel
  • Properties
  • Delete this panel
  • New panel
  • Help
  • About Panels

Trying to solve this I did what is usually suggested:

gconftool-2 –-recursive-unset /apps/panel # might be optional
rm -rf ~/.gconf/apps/panel
pkill gnome-panel

but I only got a nice empty panel (no Applications Places System, no clock, no shutdown button...) to which I couldn't add any applet, so I decided to take the default profiles in .gconf and .gconfd from a live CD and overwrite mines. Now we are back to the beginning.

I also have tried to lock completely the panel (with both gconf-editor and pessulus) and later unlock it completely but it didn't work.

Here is the system information:

$ lsb_release
Distributor ID: Ubuntu
Description: Ubuntu 10.04.2 LTS
Release: 10.04
Codename: lucid

Thank you very much.

share|improve this question
    
Are you running the desktop or netbook edition? –  Mark Rooney Mar 6 '11 at 23:01
    
Do you see the same behaviour when you log in to a different account? –  arrange Mar 6 '11 at 23:06
    
Post the link to the image, and I or someone else with enough rep will add it to your post. –  Alvin Row Mar 6 '11 at 23:12
1  
sounds like your file permissions are messed up. –  RolandiXor Mar 7 '11 at 0:30
    
1) Desktop edition 2) Yes,it is the same behaviour on the other account 3) image –  david Mar 7 '11 at 18:42

2 Answers 2

Reset Gnome.

First of all, backup your settings.

mkdir ~/backup_gnome
mkdir ~/backup_gnome/.gnome/
cp -R ~/.gnome/* ~/backup_gnome/.gnome/

Do this with these folders: .gnome, .gnome2, .gconf, .gconfd, .metacity

Another way is to backup ALL of your settings:

mkdir ~/backup_settings
cp -R ~/.* ~/backup_settings/

After making backups, you can delete all gnome settings:

rm -rf .gnome .gnome2 .gconf .gconfd .metacity

WARNING: If you remove all these folders, you essentially remove all the settings.

After resetting gnome, Logout and Login again (or restart your computer). You panels should be restored, now you can edit them again.

I hope this helped you, but try all the answers before mine, because resetting gnome is like reinstalling gnome.

Daniel

share|improve this answer

If it's something in your gnome settings that has gone wrong, you could reset them to defaults using Ubuntu Tweak. If you open Ubuntu Tweak and then look under the "Desktop Recovery" section you can restore any of several settings folders to the initial defaults.

share|improve this answer
    
Restored back to the default settings but didn't work either. All the options appeared but Add to panel, Delete this panel and New panel are not clickable. At least I didn't get an empty panel, which is something. –  david Apr 8 '11 at 12:06

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.