Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have ubuntu-server on my server and also in terminals and an application squeegee in text mode. This version 9.10 of ubuntu-serversystem came with a resolution at the terminal, which makes use of the application, the fonts (letters) are very small.

Please, if anyone knows how to take the resolution of text mode 10.04 ubuntu server, tell me. To illustrate. I need the resolution is to get as Debian, large fonts!

Still using version 9.04, it was the last that still has not implemented the resolution at the terminal (text mode). I remind you that non-use graphical interface. Only text mode.

share|improve this question

3 Answers 3

You can also dynamically change the font size after the system has booted.

The simplest way I've found is to pick a font that you like from /usr/share/consolefonts/ and pass it to the setfont command. Not all the fonts work for me (some say 'KDFONTOP: invalid argument', possibly due to my framebuffer settings), but enough do. If you want a large font, I'd suggest trying either of these commands to start with:

setfont Uni2-Terminus16
setfont Uni2-Fixed18

If you want to make your choice persist through reboots, you'll need to add a command somewhere in your startup scripts. (.bashrc will work, but you should probably try to think of somewhere better.)

The other way is to use the console-setup package. Type

sudo dpkg-reconfigure console-setup

to start it asking its questions. Accept the defaults to start with, and then after about seven or eight questions you'll be asked what font you want on the console. The font you select here will be stored in the initramfs, so that it will be reloaded automatically next time you boot.

share|improve this answer
    
On Ubuntu LTS 12.04, dpkg-reconfigure thing changes the font fine, but doesn't persist after rebooting. –  majkinetor Dec 5 '12 at 13:34
    
Are you sure? I just do this step and it works. After a while, the font change back to the one I setup in console-setup. –  swdev Oct 9 '13 at 23:42

If I understand you correctly, you are arguing about the font size in the virtual terminals (VT), accessible with CTRL + ALT + F[1-6]!?

These terminals are configured during the boot process. Depending on your version of Grub you can configure the setup to your preferred solution:

Using GRUB1 (0.9) open the file /boot/grub/menu.lst and search for lines that start with kernel /boot/... and add or change vga=xxx. A table with possible values and it's meanings can be found on wikipedia. So your kernel line should look like this:

kernel /boot/vmlinuz root=/dev/sda1 ro vga=791

Please take care not to change anything else, otherwise your machine may not boot probably anymore!

If you have installed GRUB2 (1.9) the vga parameter became deprecated. Open /etc/default/grub and set the following values:

GRUB_GFXMODE=1024x768x32
GRUB_GFXPAYLOAD_LINUX=keep

You can choose between one of these resolutions: 640×480, 800×600, 1024×768, 1280×1024, 1600×1200.

To generate a new config file run the following as root/sudo:

grub-mkconfig -o /boot/grub/grub.cfg

In some curious cases this might not work for you, you can instead also use the deprecated vga version. Add the vga= setting next to the GRUB_CMDLINE_LINUX_DEFAULT= line in your /etc/default/grub, so that this line eg looks like:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash vga=791"

In both cases, GRUB1 or GRUB2 you need to reboot to see the effect of your changes.

share|improve this answer
    
The grub-mkconfig part is not equivalent to update-grub? And it surely requires sudo. –  enzotib Jun 23 '11 at 21:02
    
Also a reference to en.wikipedia.org/wiki/… for resolution different from 1024x768 16bit colors is worth to mention. –  enzotib Jun 23 '11 at 21:05
cd /usr/share/consolefonts
ls

Choose one file filex and run setfont filex. For example:

setfont Uni3-Terminus32x16.psf.gz

And that should solve the problem.

share|improve this answer
    
Why would this increase the text size? –  Eliah Kagan Mar 29 '13 at 11:51

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.