Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I need to install Ubuntu on my USB pendrive 3.0 in order to have my "portable computer" everywhere i go. BUT i need it to work also on EFI systems. I've tryied by installing ubuntu on a VirtualBox hd (the copy of the USB pendrive) and it works if i set the VM as EFI. The problem is that it doesn't boot on other computers. I've done a manual partition with this scheme:

32GB USB pendrive:

- 150 MB: efi partition (EFI BOOT)
- 258 MB: ext2 partition (BOOT)
- the rest: ext4 partition (root)

Any ideas why the bios recognize all the partitions but when i try to boot from the efi one nothing happens? If anyone can suggest me a guide or something useful for what i'm doing it will be very kind...

Thanks in advance for the answer

share|improve this question
More information is required. As a start, try posting the output of find /boot/efi -iname "*.efi", with your 150MB EFI System Partition mounted at /boot/efi; and the output of sudo parted /dev/sdb print, changing /dev/sdb to the USB flash drive's device file. – Rod Smith May 10 '13 at 17:05
First, i'm sorry i've posted some wrong info and thanks for the answer.... Second I've runned the command you've told me in the VM and the output is: output1: /boot/efi/EFI/ubuntu/grubx64.efi output2: Model: ATA VBOXHARDDISK (scsi) HD /dev/sda: 32 GB Sector dimension (logic/physic): 512B/512B Partition table: gpt Number - Start - End - Dimension - File System - Name - Flag 1 - 1049KB - 200 MB - 199MB - fat32 - EFI_boot - Boot 2 - 200 MB - 456 MB - 256MB - ext2 - - Boot 3 - 456 MB - 5456MB - 5000MB - ext4 - - – IlGala May 11 '13 at 12:29

Mount the USB flash drive's first partition (the ESP) at /boot/efi and issue the following commands (changing /boot/efi if you mount somewhere else):

cd /boot/efi/EFI
sudo mv ubuntu boot
sudo mv boot/grubx64.efi boot/bootx64.efi
cd ~

You can then unmount the USB flash drive and it should work.

EDIT: Since the above didn't work, try something more radical:

  1. Download the binary .zip file version (not the Debian package version) of my rEFInd boot manager and unpack the .zip file.
  2. In a working boot of your USB flash drive, open a Terminal window.
  3. Type df /boot/efi to identify the device file associated with your USB flash drive's ESP.
  4. cd to the refind-bin-{version} subdirectory of the unpacked rEFInd. If you type ls you should see, among other things, a script file called
  5. Type sudo ./ --alldrivers --usedefault /dev/sdb1, changing /dev/sdb1 to the device file for your USB flash drive, as identified earlier.

In theory, at this point the USB flash drive should be bootable on more systems.

share|improve this answer
Still not working... The pc recognize the USB but when it tries to boot it shows black screen and flashing _ – IlGala May 13 '13 at 9:01
See my new suggestion, above. – Rod Smith May 13 '13 at 14:30

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.