Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've now spent hours trying and failing to figure out how to install Ubuntu Desktop 13.04 on my new desktop while setting up RAID as part of the installation.

I tried following the following two tutorials:

http://www.michielovertoom.com/linux/ubuntu-software-raid/ http://blog.foobaria.com/2010/05/installing-ubuntu-1004-desktop-with.html

Each time the installation ends with a pop-up error saying something about "'grub-install dummy' failed".

It's a PC with a pair of 120gb SSDs. It would be cool to have /boot on the mirror, but not essential. I've tried both that, and having a separate unmirrored /boot partition with the rest of the disk space dedicated to a mirrored root (/) partition (the two tutorials cover both approaches between them).


PS-It's annoying that this isn't yet a simple checkbox option during install, the way home dir encryption became a few years ago. Also, the awesome Alternate distro is no longer available for recent releases.

PPS-I've seen some people say to use 13.04 Server or 12.04 Alternate installer, then upgrade to 13.04 and install a desktop manually (if starting with Server). Is that a straightforward and safe way to end up with the equivalent of having installed Desktop 13.04 in the first place?

share|improve this question
You will find an answer in askubuntu.com/questions/294746/… –  guntbert May 19 '13 at 18:12
This is my solution, it works on 13.04 :) askubuntu.com/questions/299929/… –  user161703 May 25 '13 at 20:12

2 Answers 2

Install using a Server CD. It's a bit tricky, but it's possible.

Follow this Ubuntu community tutorial and you'll be just fine.

Afterwards, you can just add a Desktop.

Good Luck !!

share|improve this answer
Will adding Desktop afterwards result in the same system as a plain Desktop installation? –  lambdor Apr 17 '14 at 19:41

Even though this thread is a bit old...

I've found that the tutorial posted by Mike is missing a step.

After "Installing" step 6, you need to set up the mount point for the RAID device. Otherwise, you will get an error saying "no root file system is defined". This can be done by the following steps:

1. Select "#1" under the "RAID1 device #0" partition.

2. Choose "Use as:". Then select "swap area", then "Done setting up partition".

3. Next, select "#1" under the "RAID1 device #1" partition.

4. Choose "Use as:". Then select "Ext4 journaling file system".

5. Then select the "Mount point" and choose "/ - the root file system". Change any of the other options as appropriate, then select "Done setting up partition".

Finally, select "Finish partitioning and write changes to disk".

These steps are included in a more thorough tutorial found: Advanced Installation Tutorial

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.