Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just installed Ubuntu 13.04 on my Lenovo E530 laptop, and found myself having trouble connecting to the company's wireless network which uses the n-standard. I have no trouble connecting to g-networks.

After roaming the forums I found an advice to install the wicd network manager. I did so, following the instructions at Install wcid network manager. After rebooting I was asked to enter my password with the reason that "Wicd needs to access your computer's network cards". But my password was rejected as being incorrect.

After roaming some more I think I found that it wants the root password. But AFAIK the default Ubuntu setup has no such thing. In addition, the failure to give a satisfactory password is responded with a complete freeze of the entire interface, except for the mouse. I had to Alt-Ctrl-F1 out, remove wicd and reboot to be able to ask this question.

Additional info:

$ lspci | egrep -i network
03:00.0 Network controller: Intel Corporation Centrino Wireless-N 2230 (rev c4)

Any help, in particular to my original problem of being unable to connect to an n-network, is highly appreciated.

share|improve this question
    
It's a bug: bugs.launchpad.net/ubuntu/+source/wicd/+bug/1132529 I doubt Wicd will enable you to connect to an N network any easier than Network Manager. Intel products with the iwlwifi driver are indeed tricky. Does your employer also have G available? If you disable N can you connect to G? sudo modprobe -r iwldvm; sudo modprobe -r iwlwifi; sudo modprobe iwlwifi 11n_disable=1 –  chili555 May 9 '13 at 15:55
    
@chili555: Thanks. I have no trouble connecting to G the way it is now, it's just that I was told that N is more stable, and therefore wanted to make that work. So if wicd does not help me with that, I guess I don't need it. Do you know if my problem is due to a bug in the iwlwifi driver then? And if there is any fix/alternative? –  Halle Knast May 9 '13 at 16:19
    
That is a matter of debate. Some card/iwlwifi driver/router combinations, including mine, have no trouble whatever with N speeds. Others are just impossible. Since this is your employers network, you can probably not log on to the settings page of the router and fiddle with settings until it works. Frankly, I find N no more or less stable, but that may be due to the fact that are very few other networks in range at my home. If it were me, I'd disable N permanently, remove Wicd and be done. If you need guidance, post back. –  chili555 May 9 '13 at 16:36
    
Ok I will do that. However, when I run the second or third command that you gave, I get the error:Error: missing module name. FATAL: Error running remove command for iwlwifi –  Halle Knast May 9 '13 at 17:28
    
Please try: lsmod | grep iwl. In 13.04, the iwldvm or iwlmvm module needs to be unloaded first. Remove whatever you found. If not iwldvm, then do: sudo modprobe -r iwlmvm; sudo modprobe -r iwlwifi; sudo modprobe iwlwifi 11n_disable=1. If you then connect, we can write a conf file to make it permanent. –  chili555 May 9 '13 at 17:41
show 1 more comment

1 Answer 1

up vote 4 down vote accepted

Please verify that your driver is iwlwifi.

lsmod | grep iwl

If you wish to disable N speeds in order to connect seamlessly, add to one file:

gksudo gedit /etc/modprobe.d/iwlwifi.conf

At the end of the file, add a new line:

options iwlwifi 11n_disable=1

Proofread, save and close gedit. After a reboot, you should be all set. If you are able to connect to home and work networks without any issues, this is not necessary.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.