Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Few days ago I installed ubuntu 13.04 on a new machine without big issues. Today, after the boot, I have this situation:

  • grub correctly loaded and normal boot
  • normal purple screen with red dots
  • instead of normal login screen I have a black screen with an almost unresponsive mouse pointer and keyboard (they are really slow and they react with a latency of a couple of seconds)
  • Hitting multiple times Ctrl+Alt+F1 I can reach a console and there operate normally (no latency anymore)
  • I tried to restore the desktop environment giving unity to the console but it cannot start.

The only "suspect" actions that I could have done yesterday are an upgrade from the repositories and maybe, having left a usb-key plugged.

After a lot of trial-and-error, the only workaround that I found effective is to launch ubuntu in recovery mode and then, from the list, select the first field: recover normal boot (or something similar). I really cannot understand why in this way stuffs are working fine.

Do you have any idea of what the heck is going on? Thanks a lot in advance :D

share|improve this question

closed as off-topic by RolandiXor Aug 9 at 8:15

This question appears to be off-topic. The users who voted to close gave this specific reason:

If this question can be reworded to fit the rules in the help center, please edit the question.

    
Could be many things. I've personally been having problems with kernel updates not installing correctly (causing something similar to what you describe). When I get into tty terminal, I try update & upgrade and sudo apt-get install -f. Another few restarts... –  Brandon Bertelsen May 9 '13 at 13:45
    
I had a similar problem I created a bootable 13.04 usb stick using unetbootin and after a successful install. I then rebooted and I had no keyboard no mouse on start-up, or my system would not boot at all and it would get stuck on booting the usb drivers. I re-made a new bootable usb directly in ubuntu following these instructions and reinstalled and everything worked. ubuntu.com/download/desktop/create-a-usb-stick-on-ubuntu Old versions of unetbootin may not be copying files over again –  Rick T Jun 12 '13 at 14:49

Browse other questions tagged or ask your own question.