Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Yesterday I ran the graphical program that offered to upgrade my Ubuntu 12.10 system to 13.04 and it appeared to run flawlessly. By that I mean it presented no errors or warnings, ran to completion, and booted into 13.04.

However...

When I enter my password into the GUI to log in, I see a flash of a somewhat jumbled TEXT screen, and then the system returns to the login screen. If I enter the WRONG password, it just tells me that my password is wrong. Also, I verified that I CAN still log in across the network using SSH (though the MOTD tells me that I'm running 13.04 and that an upgrade to 13.04 is available!)

This isn't a huge problem because I use the machine as a network server and almost NEVER use the GUI (also, I utterly DESPISE 'unity') but since that's the recommended way to upgrade, I'll need it again someday.

Oh, I also tried running sudo apt-get update and then sudo apt-get upgrade just to be sure that everything was correctly updated and it found nothing to upgrade.

Any suggestions?

share|improve this question
    
If you had proprietary graphics drivers installed before upgrading, they were probably removed and reinstalling them might solve your issue. Also it might help to backup and then remove /etc/X11/xorg.conf, which might contain settings that don't work with the updated drivers. –  soulsource May 22 '13 at 16:20
add comment

Know someone who can answer? Share a link to this question via email, Google+, Twitter, or Facebook.

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.