Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Ubuntu 10.10, 32 bit, XTerm(261), Keyboard layout = Canadian

Somehow, the backquote (backtick = `) character can't be input does not get entered in XTerm. I type it and nothing happens. The cursor does not move forward. Nor can I type the è (e with grave). This is normally input by typing the backtick followed by an e. I can type the accented é into XTerm as it is a key on the keyboard.

I know it works because I can input the ` backtick and è etc in Terminal (gnome-terminal).

I don't want to change the keyboard layout. termcap? terminfo? maybe that has something to do with it ... something is intercepting that backtick ... all other special characters can be input without problem.

Someone please help me solve this mystery. I like to use XTerm and I need the backquotes.

share|improve this question
    
Two questions: What's the value of your LANG environment variable, and is this a French Canadian keyboard? –  Wesley Rice May 24 '11 at 20:37

1 Answer 1

up vote 1 down vote accepted

On foreign keyboards, there are dead keys - of which the backtick is one in languages like French. The standard response - as you mentioned - is to do nothing and present the accented è when an "e" is pressed (other letters would be similar).

I thought that following the backtick by a space would make a backtick appear alone.

I would check your locale (all LC_* settings) in xterm. I would also check the setting of TERM. You can do these by doing this:

locale
set | grep LC_
echo $TERM

The first two commands should present the same information.

I would also expect that gnome-terminal is much more compatible with foreign languages than xterm.

share|improve this answer
    
Thanx for the reply. That was so simple. The backtick does appear when pressing space after the tick! I wonder how I missed that. BTW, I have moved to Fedora 15 now. I couldn't tolerate the FF crashes on Natty any longer. –  Cocoro Cara Jun 6 '11 at 18:57

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.