Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

on my Ubuntu server 12.04.2, LVM partition, I have this problem when I run apt-get -f install :

apt-get-f install
Reading package lists ... done
Building dependency tree
Reading state information ... done
Correcting dependencies ... done
The following packages were automatically installed and are no longer needed:
   linux-image-3.2.0-37-generic linux-headers-3.2.0-37 linux-headers-3.2.0-37-generic
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
   linux-server
The following packages will be upgraded:
   linux-server
1 upgraded, 0 newly installed, 0 to remove and 61 not upgraded.
1 not fully installed or removed.
It is necessary to o 1736 in the archives.
After this operation, 1024 o of additional disk space will be used.
Do you want to continue [Y / n]? o
Reception: 1 http://fr.archive.ubuntu.com/ubuntu/ precise-updates/main linux-server amd64 3.2.0.41.49 [1736 B]
1736 o approved in 0s (57.2 kB / s)
dpkg: dependency problems prevent configuration of linux-server:
  linux-server depends on linux-image-server (= 3.2.0.39.47), however:
   The version of linux-image-server on the system is 3.2.0.41.49.
  linux-server depends on linux-headers-server (= 3.2.0.39.47), however:
   The version of linux-headers-server on the system is 3.2.0.41.49.
dpkg: error processing linux-server (- configure):
  dependency problems - leaving unconfigured
No "contribution" report was created because the error message indicates an error running a previous failure.
                           Errors were encountered while processing:
  linux-server
E: Sub-process / usr / bin / dpkg returned an error code (1)

I tried to download linux-server_3.2.0.39.47_amd64.deb and dpkg -i linux-server_3.2.0.39.47_amd64.deb but it says kernel already installed.

Any idea ? Thank you.

share|improve this question

1 Answer 1

up vote 3 down vote accepted
wget https://launchpad.net/ubuntu/+archive/primary/+files/linux-server_3.2.0.41.49_amd64.deb
dpkg -i linux-server_3.2.0.41.49_amd64.deb
share|improve this answer
    
Seemed too easy, but fixed the same problem for me! (different versions, but same error) :) –  superlime Sep 12 '13 at 7:15

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.