Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just installed Ubuntu 13.04 in my laptop Aspire-M3-5871TG, and I can't see anything (neither icons, ...). Only is visible the desktop background but I can open and work with the terminal. Maybe the problem is related with Nvidia Geforce GT 640M vs Unity.

I've tried several commands:

dconf reset -f /org/compiz/ 
unity --reset-icons &disown

and

unity --replace &

but nothing happens.

I've tried other commands as well:

sudo add-apt-repository ppa:ubuntu-x-swat/x-updates
sudo apt-get update
sudo apt-get install nvidia-current

and nothing happens.

I've also tried to install tweak but is it not possible to find it. Thus, I can't do nothing ...

Definetely my laptop is not compatible with Ubuntu 13.04?

share|improve this question

3 Answers 3

I've fixed the problem with icons: I have installed again Ubuntu 13.04 with bootable cd.

Now unity works but the system do not recognize nvidia (the real problem), it recognize Intel Sandybridge Mobile). I'm trying to install proper drivers with NVIDIA-Linux-x86_64-319.17.run but I'm not able to execute the file/program. I've tried from terminal:

apt-get install -f NVIDIA-Linux-x86_64-319.17.run

but it doesn't work.

Help and comments will be apreciated; thanks.

share|improve this answer
    
I've installed again ubuntu 13.04 in my laptop but the problem has happened again: all the icons in the desktop has dissapeared; I can not do nothing, again the desktop is empty! (it's very frustating because I had been installed virtualbox (windows7 guest) with shared folders, R program, kile, etc. I've spended more than one week preparing my latpop to work and now I must to begin again!! What is the problem? –  Edgar May 12 '13 at 10:48

Try issuing

rpm -qa | grep -i nvidia

and comparing to:

apt-cache search nvidia (or repo search nvidia)

Be sure about what you have installed.

I had similar problems but it turned out to be resolution related, I had to re-install. But mainly because I wasn't sure where I'd gone wrong since I had to wrestle Desktop onto the system.

With my laptop (An HP G7 Pavillion) I had to boot the Ubuntu Desktop 13.04 bootable disk, then down arrow to "Install Ubuntu", press F6, and choose "NOAPIC" option, and then after escaping the F6 macro I then had a bootable line with --OPTIONS to which I added vga=711

The reason for all of this was to get Ubuntu to boot and install using a more basic video mode, because it was trying to run the installer at a higher resolution than what the video card was prepared to display, because the video card is part of the card bridge and the chipset driver wasn't yet loaded.

Once I was able to trick the installer into running in a low-res mode the automatic hardware discovery within setup did the rest for me, post setup reboot everything was working properly except NIC and Sound. (See below)

Also, to get my system working all around, wifi etc, I had to install 'pciutils' and issue the "lspci --n ..." a few times to see what card versions I had on board, etc..

In Some cases you might also need to load the kernel-headers for your system (uname -ar) and perhaps some firmware as well {such as in my case module bcm had to be blacklisted, and bcmrma had to be enabled, etc..)

Hope this helps you.

share|improve this answer

I'm sure that you are doing or installing the same thing each time, but oddly enough you don't seems to mention it. You should create another user, then see if it happens there. If it doesn't, then the problem is your user configuration. Doing rm -r ~/.* in the terminal and reboot should fix the problem.

If the new user has the same problem, then is a system wide program that causes this. Removing one by one, deleting the hidden files at each try and rebooting until you find the root cause.

Problems that appears after the user installing programs and that repeats between releases are normally about rouge programs that mess up the configuration. You should report a bug against the package. Follow the instructions on filing a bug report and provide the link here.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.