Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Since I've updated from 12.10 to 13.04, desktop environment freezes on each startup. My GPU is ATI Radeon HD 4670 (RV730), driver fglrx-updates is installed, Linux 3.8.0-19-generic, 64-bit system. Should I use another driver to fix the problem? Had anybody have the same problem?

share|improve this question

1 Answer 1

up vote 3 down vote accepted

Parts 1-3 are suggesting Radeon HD 4670

Part 1

My answer comes 1 month later after the question but if you haven't cleared the issue meanwhile, maybe this helps.

As long as the AMD Radeon HD 4000 Series are concerned, AMD isn't providing support beyond specific Kernel version (3.4) and Xserver version (1.12). They are considering this cards legacy.

You can read about this in the footnote of the official AMD drivers download link for Linux (x86/x86_64): http://support.amd.com/us/gpudownload/linux/legacy/Pages/legacy-radeon_linux.aspx

This actually means that if you want 3D acceleration in Ubuntu for AMD Radeon HD 4000 Series you can go as far as Ubuntu 12.04 LTS (that has Kernel 3.2 and Xserver 1.10).

Ubuntu 12.10 has Kernel 3.5 and Xserver 1.13. Ubuntu 13.04 has Kernel 3.8 and Xserver (still) 1.13.

So, even if you managed to install fglrx in Ubuntu 12.10, it doesn't work at all (but at least it doesn't crash your system). On Ubuntu 13.04 things seem to get worse - from your post - with the system freeze.

I know all this because I also have a HD 4670 card and I've tried to install accelerated drivers for Ubuntu 12.10, run into problems and tried to get to the bottom of the issues. I now run Ubuntu 13.04 with the open source drivers for HD 4670.

Part 2

If up to now it's not very clear: you should remove any fglrx driver from your system as it doesn't really work at all (for all the reasons previously explained) and can only lead (in the worst case) to system freeze. There is no fglrx driver (Ubuntu provided or AMD provided) that supports HD 4670 on Ubuntu 13.04 (or 12.10 as well).

Part 3

What I suspect first and foremost is that fglrx is creating a custom xorg configuration file [/etc/X11/xorg.conf] on install and "forgets" to remove it on uninstall which will throw your graphics into the woods when you restart.

If you've got the time/mood for it, you can try this:

  1. as I understand you now have fglrx installed, please check for the presence of file [/etc/X11/xorg.conf]. If the file is present then continue with 2. else just stop now and do nothing more;

  2. remove fglrx. Immediately after removing fglrx (but before re-booting) check again the presence of file [/etc/X11/xorg.conf]:

    • If the file isn't there anymore this means my guess was not correct and you probably should install back fglrx so your system can boot to the desktop.
    • But if the file it's still there just rename/delete it and reboot next.

Part 4

As you indicate that you actually have a HD 5670, this is a totally different situation.

If you go to http://support.amd.com/US/GPUDOWNLOAD/Pages/index.aspx and put the right parameters (Desktop Graphics, Radeon HD Series, Radeon HD 5xxx Series PCIe, Linux x86_64) you'll see that your video card is still current and AMD provides drivers for it that should work in Ubuntu 13.04 (see the note about Xserver up to 1.13 but note there's nothing mentioned about the Kernel version). There are 2 driver versions: stable is 13.4 and beta is 13.6.

You have 2 options:

  1. open in Ubuntu "Software & Updates" and go to the last tab [Additional Drivers]. Ubuntu should suggest what options you have (if any). If fglrx or fglrx-updates is listed as an option it is a little strange it didn't work for you already (maybe it wasn't correctly/fully installed) and maybe you can try it again (but install from [Additional Drivers] if you didn't before). If no option appears it means that none of fglrx or fglrx-updates provided in Ubuntu 13.04 don't support HD 5670 and you should see option 2 next;

  2. if there's no option at 1. or if no option works (I've checked with synaptic for Ubuntu 13.04 and if Ubuntu fglrx version numbers follow AMD driver version numbers, the versions from Ubuntu 13.04 are rather old: 9.10 for fglrx and 9.12 for fglrx-updates) than try one of the drivers from AMD site (I would recommend to try first the stable version and only if this doesn't work, try the beta version). Be advised that, no matter the stable or beta version, you'll have to manage installation (& uninstallation, if needed) independently from the Ubuntu package management.

share|improve this answer
    
In my system freezes have gone after one of regular updates. Then returned, then gone again. –  leventov Jun 6 '13 at 23:07
    
Thanks, you was right. Although I've incorrectly stated my GPU is Radeon HD 4670 (HD 5670 indeed), your recipe helped me to solve the problem. –  leventov Jun 14 '13 at 15:29
    
Your should probably compile your asnwers into this and delete 2 other ones. I have accepted this answer because it is the only one currently upvoted by anybody except me. The recipe mentioned above is from the 3rd answer. –  leventov Jun 14 '13 at 15:32
1  
You seem to be using two different accounts, please see meta.askubuntu.com/a/687/117103 about how to get them merged. –  guntbert Jun 17 '13 at 19:01

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.