Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Hi! I tried mode switching, but it always fails to switch. The USB storage is detached, but the mode switching fails and the product id stays at "1446" and doesn't change to "1506". Here is the script that I am using:

DefaultVendor= 0x12d1  

TargetVendor=  0x12d1


MessageEndpoint= 0x01

Source: .

share|improve this question

1 Answer 1

up vote 1 down vote accepted

I found a solution add -I to the command. I hope this helps. So the command would be something like this.

sudo usb_modeswitch -v 0x12d1 -p 0x1446 -V 0x12d1 -P 0x1506 -m 0x01 -M 55534243123456780000000000000011062000000100000000000000000000  -I 

Or you can use a config file and add -I.

share|improve this answer
Awesome! Ive tried everything to get my Huawei E367 to work on my Raspberry Pi, and nothing worked. Youre -I saved my day/week :-) You should really mark your own answer as accepted. Thx – Lars Udengaard Sep 18 '14 at 18:23

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.