Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

time zone here is Asia/Tehran, but the ubuntu time is 5H30M ahead of local time.

I've checked configs and even installed ntp server, nothing seem to fix this,

sudo dpkg-reconfigure tzdata

Current default time zone: 'Asia/Tehran'
Local time is now:      Thu May  9 00:49:38 IRDT 2013.
Universal Time is now:  Wed May  8 20:19:38 UTC 2013.


driftfile /var/lib/ntp/ntp.drift

statistics loopstats peerstats clockstats
filegen loopstats file loopstats type day enable
filegen peerstats file peerstats type day enable
filegen clockstats file clockstats type day enable



restrict -4 default kod notrap nomodify nopeer noquery
restrict -6 default kod notrap nomodify nopeer noquery

restrict ::1

Here are current situation

$ date
    Sun May 12 17:15:39 IRDT 2013
$ date --utc
    Sun May 12 12:45:40 UTC 2013
according to Google my local time is 
    11:45 AM Sunday, May 12, 2013 (IRDT)
share|improve this question
I don't see a problem with the output what time does your clock say, what time dose your computer say (via the date command) and what time does the internet say (from an NTP site)? – coteyr May 8 '13 at 18:25
To get part of the info @coteyr wants, type date and then date --utc, put both outputs into your question along with the value you did expect.` – guntbert May 8 '13 at 21:12
Trying to fix time with $ ntpdate 12 May 17:21:49 ntpdate[4217]: no servers can be used, exiting while I can dig the time servers with no problem. – Saeed May 12 '13 at 7:23

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.