Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

The Touchpad on my Dell laptop is an annoyance; while typing, if I inadvertantly strike
it, the "I-beam" (or Mouse Pointer) ends up somewhere other than where I want it.

None of the settings I have tweaked thus far will kill the touchpad.

share|improve this question

2 Answers 2

Actually, the best way I found is to open Terminal and type:

xinput list

Your touchpad should show up in there somewhere. Make note of the touchpad's full name. Then, in your Startup Applications, make a new entry and put in:

xinput set-prop "ETPS/2 Elantech Touchpad" "Device Enabled" 0

Where I have ETPS/2 Elantech Touchpad, put in the full name of your touchpad and save it. Make sure the touchpad's name is wrapped in quotes. Now every time you log into Ubuntu, the touchpad will be disabled. You can uncheck it in Startup Applications to stop this behavior or run that command in terminal with a 1 instead of a 0 to enable it again.

share|improve this answer

Try installing the Synaptik touchpad manager from Ubuntu Software Center. It has the option to disable touchpad while typing...and many more options.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.