Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just bought the Humble Double Fine Bundle and downloaded the .bin file, and it says it uses the mojo installer.

When I'm trying to open the installer I get this error:

jeggy@jeggy-XPS:~/Niðurtøkur$ sudo ./CostumeQuest-Linux-2013-05-07-setup.bin
./CostumeQuest-Linux-2013-05-07-setup.bin: error while loading shared libraries: libbz2.so.1: cannot open shared object file: No such file or directory

I googled and I found this: enter image description here
And that looks just like my problem, but the link is dead now :/

I am running Ubuntu 13.04 64bit

EDIT:

It says I have libbz2-1.0 installed

jeggy@jeggy-XPS:~/Niðurtøkur$ sudo apt-get install libbz2-1.0
Reading package lists... Done
Building dependency tree       
Reading state information... Done
libbz2-1.0 is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

ldd:

jeggy@jeggy-XPS:~/Niðurtøkur$ ldd ./CostumeQuest-Linux-2013-05-07-setup.bin
linux-gate.so.1 =>  (0xf77a9000)
libpthread.so.0 => /lib/i386-linux-gnu/libpthread.so.0 (0xf7769000)
libbz2.so.1 => not found
libdl.so.2 => /lib/i386-linux-gnu/libdl.so.2 (0xf7763000)
libm.so.6 => /lib/i386-linux-gnu/libm.so.6 (0xf7720000)
libc.so.6 => /lib/i386-linux-gnu/libc.so.6 (0xf756d000)
/lib/ld-linux.so.2 (0xf77aa000)




jeggy@jeggy-XPS:~$  sudo find / -name libbz2.so.1
[sudo] password for jeggy: 
/home/jeggy/.local/share/Steam/ubuntu12_32/steam-runtime/i386/lib/i386-linux-gnu/libbz2.so.1
/lib/x86_64-linux-gnu/libbz2.so.1

It took very long until I got response from that command.

share|improve this question
    
Please update your question with the output of ldd ./CostumeQuest-Linux-2013-05-07-setup.bin (as the output should be lengthy use some paste service like paste.ubuntu.com). –  Salem May 8 '13 at 14:48
1  
In case you wanted that link: here it is –  Yet Another User May 8 '13 at 23:57
1  
sudo find / -name libbz2.so.1 > it took me about 7.47 secs , if you want speed you should have an SSD –  Qasim May 9 '13 at 14:50

5 Answers 5

up vote 4 down vote accepted

Simple Way To Fix The Error

 sudo find / -name libbz2.so.1

The Output is

 /var/cache/lxc/centos/x86_64/6/rootfs/lib64/libbz2.so.1
 /var/cache/lxc/raring/rootfs-amd64/lib/x86_64-linux-gnu/libbz2.so.1
 /var/lib/lxc/centos/rootfs/lib64/libbz2.so.1
 /var/lib/lxc/container/rootfs/lib/x86_64-linux-gnu/libbz2.so.1
 /var/lib/lxc/juju/rootfs/lib/x86_64-linux-gnu/libbz2.so.1
 /var/lib/lxc/client/rootfs/lib/x86_64-linux-gnu/libbz2.so.1
 /lib/x86_64-linux-gnu/libbz2.so.1
 /lib/i386-linux-gnu/libbz2.so.1

Then Simply You Need To Load This Lib libbz2.so.1 Before Executing

For 32 bit app

 LD_PRELOAD=/lib/i386-linux-gnu/libbz2.so.1 ./CostumeQuest-Linux-2013-05-07-setup.bin

If that work Then simple Check the this answer Skype Crashes with a Segmentation fault

OR

  sudo ln -s /lib/i386-linux-gnu/libbz2.so.1 /usr/lib32/
  sudo ldconfig -v

Then Run The Setup


Update

Make a file

 sudo gedit /etc/ld.so.conf.d/hib.conf

Copy paste the following line in it

 /home/jeggy/.local/share/Steam/ubuntu12_32/steam-runtime/i386/lib/i386-linux-gnu/
 /lib/x86_64-linux-gnu/
 /lib/i386-linux-gnu/

Save & exit & then run the following command

  sudo ldconfig -v

Lastly run the setup

 sudo ./CostumeQuest-Linux-2013-05-07-setup.bin

Solved With Google + Screen Sharing

 sudo cp /home/jeggy/.local/share/Steam/ubuntu12_32/steam-runtime/i386/lib/i386-linux-gnu/libbz2.so.1.0.4 /usr/lib/libbz2.so.1

 sudo ldconfig -v

Lastly run the setup

 sudo ./CostumeQuest-Linux-2013-05-07-setup.bin
share|improve this answer
    
the second one didn't work, and i updated the question with the output of the first one, it looks like it has something to do with Steam. –  Jeggy May 9 '13 at 13:47
    
@Jeggy please check the update ........ –  Qasim May 9 '13 at 14:23
    
I followed your update and got the same error :/ hib.conf was empty, don't know if it was supposed to be empty. –  Jeggy May 9 '13 at 15:47
1  
Thanks for your help! :D –  Jeggy May 9 '13 at 17:11
2  
@Seth yes its working ...last screen was start up menu of the game ..google screen sharing –  Qasim May 9 '13 at 17:37

Make sure you look in the /usr/lib*32* folder to create the symlink (and of the library in that folder, not from the lib folder as that is 64bit).

The installer seems to be 32 bit (obvious when you look at the output of ldd). After creating an extra symlink to libbz2.so.1 in the lib32 folder it installed fine. (although it did spam some more exception messages)

share|improve this answer
    
Hohum, 32bit is actually not installed by default so you'll have to install it... (sudo apt-get install lib32bz2-1.0) (I'm still on 10.04, but I rechecked with a newer version) –  Highway May 9 '13 at 0:09

You can install libbz2 like this

sudo apt-get install libbz2-1.0
share|improve this answer
    
I updated the question with my output with that command –  Jeggy May 8 '13 at 13:55
    
The bin file which you downloaded is for 64bit version only? –  thefourtheye May 8 '13 at 13:57
1  
sudo apt-get install libbz2-1.0:i386 should do it if you are using 64bit assuming you are right about the library file, you could just install ia32-libs –  GM-Script-Writer-62850 May 8 '13 at 23:58

Try finding where the libbz2.so are installed to and make a symlink/copy to libbz2.so.1. It's usually in /usr/lib/ if I recall correctly.

IMPORTANT: To anyone trying this, make sure to remove the library afterwards. This kind of fiddling is supposed to be only for debugging/workaround, not a permanent solution.

share|improve this answer
    
I believe they ll be picked up automatically if they are in /usr/lib. –  thefourtheye May 8 '13 at 14:26
    
I looked in /usr/lib and it isn't there :/ –  Jeggy May 8 '13 at 23:18
    
I just looked at my Ubuntu machine, and found the libraries in these location: /lib/i386-linux-gnu/libbz2.so.1, /lib/i386-linux-gnu/libbz2.so.1.0.4, /lib/i386-linux-gnu/libbz2.so.1.0, /lib/x86_64-linux-gnu/libbz2.so.1, /lib/x86_64-linux-gnu/libbz2.so.1.0.4, /lib/x86_64-linux-gnu/libbz2.so.1.0. –  Lie Ryan May 9 '13 at 1:04
    
However, check out the other suggestions about installing the 32-bit version of the library since it seems the installer is a 32-bit only binary. Those seems like a better solution. –  Lie Ryan May 9 '13 at 1:12

Open a terminal, use cd to navigate to download directory. Type:

chmod u+x *filename*

Hit enter then type:

./*filename*

Additional details: this works on Ubuntu 13.04 x64, and I simply typed the file names WITH NO EXTENSIONS (i.e. no .bin etc.)

This should open the installation prompt in the terminal.

share|improve this answer
    
i tried that, but it didn't work for me. see the accepted answer to see what i needed to do to fix the problem –  Jeggy May 11 '13 at 22:51

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.