Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My system locale is en_DK.utf8 and I want ISO-dates (yyyy-mm-dd) everywhere.

% locale
LANG=en_US.UTF-8
LANGUAGE=en_DK:en
LC_CTYPE="en_DK.utf8"
LC_NUMERIC="en_DK.utf8"
LC_TIME="en_DK.utf8"
LC_COLLATE="en_DK.utf8"
LC_MONETARY="en_DK.utf8"
LC_MESSAGES="en_DK.utf8"
LC_PAPER="en_DK.utf8"
LC_NAME="en_DK.utf8"
LC_ADDRESS="en_DK.utf8"
LC_TELEPHONE="en_DK.utf8"
LC_MEASUREMENT="en_DK.utf8"
LC_IDENTIFICATION="en_DK.utf8"
LC_ALL=en_DK.utf8

If I start Thunderbird from the command line, the dates are correct. However, when starting it from a menu, the dates are in mm/dd/yyyy-format no matter what I do.

I've tried ConfigDate and QuickLocaleSwitcher, none of them are capable of changing the date-format in Thunderbird if started from a menu. I've also tried setting things in dconf, same result:

% dconf write /com/canonical/indicator/datetime/time-format "'custom'"
% dconf write /com/canonical/indicator/datetime/custom-time-format "'%F %R'"

So: How can I force Thunderbird to use the date format I want, even when started from a menu?

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

I found this it appears to be what you want
http://www.my-guides.net/en/guides/linux/how-to-change-thunderbirds-date-format-in-date-column
export LC_TIME=en_DK.UTF-8 && thunderbird
oh and i did test it here

share|improve this answer
    
In KDE4 it is in addition necessary to remove all existing short cuts, for instance in Favorites, because existing short cuts remember the old, wrong behavior. After doing that, it works! –  kaleissin May 8 '13 at 13:28
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.