Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to install Java onto my Ubuntu 11.10. I've managed to get some repositories from where to download the installer, but whenever it gets to the point of updating the resources (a.k.a. sudo apt-get update), it dies. And now, let me explain what I mean by death: so when it starts updating, it automatically tries to connect to port 8080, which takes some time. After that it gets this error message that it couldn't resolve port 8080. The % loader gets to @25 and than it stops indefinitely. I don't know what to do. I've tried accessing from my local (home) network, from my working network (and from my University network also), and it still shows the same errors.

I will post now the console messages that keeps spawning when it tries to update the resources:

root@ubuntu:/home/lucaciandrei# apt-get update
Ign http://ppa.launchpad.net oneiric InRelease
Ign http://archive.ubuntu.com oneiric InRelease
Ign http://ppa.launchpad.net oneiric InRelease 
Err http://archive.ubuntu.com oneiric Release.gpg
  Something wicked happened resolving 'proxy:8080' (-5 - No address associated with hostname)
Ign http://ppa.launchpad.net oneiric InRelease 
Ign http://archive.ubuntu.com oneiric Release  
Ign http://ppa.launchpad.net oneiric InRelease 
Ign http://ppa.launchpad.net oneiric InRelease 
Err http://ppa.launchpad.net oneiric Release.gpg
  Something wicked happened resolving 'proxy:8080' (-5 - No address associated with hostname)
Ign http://archive.ubuntu.com oneiric/universe TranslationIndex
Err http://ppa.launchpad.net oneiric Release.gpg
  Something wicked happened resolving 'proxy:8080' (-5 - No address associated with hostname)
Err http://ppa.launchpad.net oneiric Release.gpg
  Something wicked happened resolving 'proxy:8080' (-5 - No address associated with hostname)
Err http://ppa.launchpad.net oneiric Release.gpg
  Something wicked happened resolving 'proxy:8080' (-5 - No address associated with hostname)
Err http://ppa.launchpad.net oneiric Release.gpg
  Something wicked happened resolving 'proxy:8080' (-5 - No address associated with hostname)
Ign http://ppa.launchpad.net oneiric Release   
Ign http://ppa.launchpad.net oneiric Release   
Ign http://ppa.launchpad.net oneiric Release   
Ign http://ppa.launchpad.net oneiric Release   
Ign http://ppa.launchpad.net oneiric Release   
Ign http://ppa.launchpad.net oneiric/main TranslationIndex
Err http://archive.ubuntu.com oneiric/universe amd64 Packages
  Something wicked happened resolving 'proxy:8080' (-5 - No address associated with hostname)
Err http://archive.ubuntu.com oneiric/universe i386 Packages
  Something wicked happened resolving 'proxy:8080' (-5 - No address associated with hostname)
Ign http://ppa.launchpad.net oneiric/main TranslationIndex
Err http://archive.ubuntu.com oneiric/universe Translation-en_US
  Something wicked happened resolving 'proxy:8080' (-5 - No address associated with hostname)
Err http://archive.ubuntu.com oneiric/universe Translation-en
  Something wicked happened resolving 'proxy:8080' (-5 - No address associated with hostname)
25% [Connecting to proxy]                      

Ps: I've searched on google/stackoverflow, but no answer seemed reasonable for my problem.

The DNS are ok, nothing changed there. Also, I used google's public DNS and server, still no update on the situation.

I don't use any proxy settings, that's the weirdest part. It's set to off, applied system wide. Tried to do it by the Ubuntu Software Center, still no updates, the same thing: stuck at updating the resources.

Also, I've seen a lot of advices to ping certain websites, such as google: I did, and it worked, and I received data, but still, no real solution to this matter at hand.

Edit: Well, I found a way around this situation. The link which Oli provided helped me. I went into my file /etc/apt/apt.conf and it was like this:

Acquire {
Retries "0";
HTTP {
Proxy "http://proxy:8080";
};
};

So what I did was to comment the lines regarding the proxy

Acquire {
#Retries "0";
#    HTTP {
#        Proxy "http://proxy:8080";
#    };
};

And that solved my proxy-connection problem. Now I'm dealing with some errors related to java as an installer. (Extracted java from the .tar.gz file I'd downloaded from Oracle, put it into my /usr/lib/jvm folder, but it won't actually let me use it, saying that lucaciandrei@ubuntu:~$ java -version bash: /usr/bin/java: No such file or directory ) But that's another question, for another topic. Thanks for your responses, Oli response will be mark as accepted, since it provided the work-around to my problem.

share|improve this question
1  
Ubuntu 11.10 support ends on May 9. That's tomorrow. I suggest you upgrade to 12.04. –  Warren Hill May 8 '13 at 7:19
    
I've seen the announcement. Well, it's sad, in a way. But no worries, since I couldn't install java on my 11.10, currently I'm upgrading to 12.04. Thanks for the heads up though. –  Lucaci Andrei May 8 '13 at 12:16
add comment

1 Answer

up vote 1 down vote accepted

Sounds like apt's proxy configuration is seriously incorrect. I would guess you've either made a typo in the name of the proxy or you're trying to point to a local hostname that your system cannot look up.

Either way, two suggested fixes:

Edit: On second look, it seems your configuration is looking for a proxy at proxy so that's what you want to add to your hosts file (assuming there even is a proxy). You can run ping proxy to confirm that it's not getting looked up correctly.

share|improve this answer
    
Well I did tried to ping it, and this is what I got:lucaciandrei@ubuntu:~$ ping proxy ping: unknown host proxy –  Lucaci Andrei May 8 '13 at 8:45
    
@LucaciAndrei I don't know your network setup. If there is a proxy, get the proper hostname, get the proper IP and plumb that into both the /etc/hosts and apt proxy configuration. If there is no proxy, clear apt's proxy settings. –  Oli May 8 '13 at 9:23
    
The issue relied in the apt proxy config. –  Lucaci Andrei May 8 '13 at 10:23
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.