Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've multiple screens i.e. one computer monitor and one TV. It would be preferable if, when the TV is turned off, nothing is sent to the TV but as it happens, I can have the TV turned off and doubleclick a PDF document and then it seems to appear nowhere since it is sent to the television which is turned off. This behavior is somewhat illogical (though I'm happy that multiple screens work so that I can play a movie on the TV and have a desktop with another monitor with my work) so could you tell me how I can do to resolve it? I'm using a Dell Optiplex 745 with a graphics card with double DVI out, I don't use HDMI but a DVI to HDMI cable and I believe that the cable is good.

enter image description here

share|improve this question
    
I'm not sure exactly what you're looking for, but one way would be to run the System Settings, Display app, and turn off that display. The command is "gnome-control-center display" if you don't want to look for it in the menu. Then just click on the TV display, and click on the on/off switch below. –  Marty Fried May 20 '13 at 1:38

2 Answers 2

up vote 1 down vote accepted

I have run into this problem as well with my dual monitor setup. I find the easiest solution is to use keyboard shortcuts to get hidden windows back, especially because I try to minimize plugging/unplugging my cables.

  • Get CompizConfig Settings Manager
    • sudo apt-get install compizconfig-settings-manager
  • In Window Management, enable Put and click to enter Put settings
  • Put within viewport >> Put Left & Put Right
    • I like super + alt + left/right

Now when you open a window and it's on the wrong screen, you can use your keyboard shortcut to get it back quickly.

I often have to hit the left or right key twice, as the first just scoots it to the edge of the screen. "Put to adjacent viewport" should do this in one stroke, but the function is broken and instead switches between Workspaces. This is why I use Put within viewport.

Side tip: Under System Settings > Displays, make sure your TV is the one on the right (even if it's not physically on the right) to make it more likely that programs will default to the monitor.

share|improve this answer

Seems like the TV as a display is being detected even after being switched off. Just pulling out the dvi cable, if it is easily accessible from your seat, should work ;)


If it isn't, then use the following command to turn of the TV as a monitor.

xrandr --output XXX --mode HRESxVRES --output YYY --off

Here XXX is the name of your primary display. YYY is the name of your TV. HRESxVRES is the resolution you want to set your primary monitor to.


To figure out what XXX and YYY are, inspect the output of the command xrandr --current when both monitors are on and being used.

XXX will most probably either be LVDS1 or VGA1 and YYY is most probably DVI1.

In addition, the output will also contain the allowed values for HRESxVRES.


You may choose to add an alias for the command or add a launcher button that executes the command.

share|improve this answer
1  
xrandr --output XXX --mode HRESxVRES --output YYY --mode HRESxVRES --right-of XXX will bring back the old status –  Germar May 25 '13 at 22:17

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.