Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

I'm using 64 bit version of Ubuntu 10.10 and have some problems with broken dependencies. I needed Adobe Air but it was not availble via apt-get, so I downloaded it from Adobe and installed. Then I succesfully installed adobe air application. It started and works pretty good. However when I start synaptic it claims that I have broken package (it is my adobe air application with some numbers attached). It says that this application requires adobeair package which can't be found in repositories and thus it can't be installed. But I have it and it works.

Do you know any workaround? For example how to tell dpkg that I have adobeair installed, or how to remove my application from list of installed packages? I haven't installed it via dpkg or apt-get, but with adobe air installer, so I don't need it to be registred in dkpg

However I have adobeair package:

dpkg --list |grep adobeair
ii  adobeair            2.5.1.17730           Adobe AIR 2

And still apt-get says:

 someapp.a1909296681c7acefe45687d3a64758c8659bf46.1 : PreRequire: adobeair (>= 2.0.0.0) but it can't be installed

Above line was in other language and I translated it to english, so original text can be different.

share|improve this question

marked as duplicate by Aditya, Alvar, Lekensteyn, blade19899, Eric Carvalho Dec 30 '13 at 12:55

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

add comment

1 Answer 1

up vote 3 down vote accepted

I would advise you to uninstall the manually installed version and then download this deb and install it. (Packaged by prakash advani here)

share|improve this answer
    
I have the Canonical Partner Repository enabled, but it seems to not include adobeair package for Ubuntu 10.10 (64 bit version), so I can't install it like in your answer. –  klew Mar 6 '11 at 11:00
    
didn't notice the 64-bit.edited and included the 64-bit deb. –  Alaukik Mar 6 '11 at 11:09
    
Thanks, I already found this blog post and it works. Solution provided in your links looks similar, so I accept your answer. Thanks! –  klew Mar 6 '11 at 11:49
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.