Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've recently installed Ubuntu, and tried installing steam. It wouldn't start so naturally I went "Google has the answer", and it had. My problem is this: this line won't run.

sudo dpkg --add-architecture i386

It tells me this when I enter it: dpkg: error: unknown option --add-architecture.

share|improve this question

Try to follow this guide: Steam Quick Install

There's a part there for x64 :) Worked for me

share|improve this answer
That's not helpful, as that guide has the failing step in it. – Yet Another User May 7 '13 at 20:59

The version of APT in 12.04 is slightly older than the time they fixed multiarch support. Your error is because of the version of APT not supporting multiarch properly. That guide only, as far as I know, works on 12.10 and newer.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.