Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I run Ubuntu 13.04 and I use Rhythmbox 2.98. This version is full of bugs and I would like to downgrade to 2.97 or older

How can I do this ? Thanks

Here is my sources.list

# deb cdrom:[Ubuntu 13.04 _Raring Ringtail_ - Release amd64 (20130424)]/ raring main restricted

# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.
deb http://fr.archive.ubuntu.com/ubuntu/ raring main restricted
deb-src http://fr.archive.ubuntu.com/ubuntu/ raring main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb http://fr.archive.ubuntu.com/ubuntu/ raring-updates main restricted
deb-src http://fr.archive.ubuntu.com/ubuntu/ raring-updates main restricted

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb http://fr.archive.ubuntu.com/ubuntu/ raring universe
deb-src http://fr.archive.ubuntu.com/ubuntu/ raring universe
deb http://fr.archive.ubuntu.com/ubuntu/ raring-updates universe
deb-src http://fr.archive.ubuntu.com/ubuntu/ raring-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu 
## team, and may not be under a free licence. Please satisfy yourself as to 
## your rights to use the software. Also, please note that software in 
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://fr.archive.ubuntu.com/ubuntu/ raring multiverse
deb-src http://fr.archive.ubuntu.com/ubuntu/ raring multiverse
deb http://fr.archive.ubuntu.com/ubuntu/ raring-updates multiverse
deb-src http://fr.archive.ubuntu.com/ubuntu/ raring-updates multiverse

## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
deb http://fr.archive.ubuntu.com/ubuntu/ raring-backports main restricted universe multiverse
deb-src http://fr.archive.ubuntu.com/ubuntu/ raring-backports main restricted universe multiverse

deb http://security.ubuntu.com/ubuntu raring-security main restricted
deb-src http://security.ubuntu.com/ubuntu raring-security main restricted
deb http://security.ubuntu.com/ubuntu raring-security universe
deb-src http://security.ubuntu.com/ubuntu raring-security universe
deb http://security.ubuntu.com/ubuntu raring-security multiverse
deb-src http://security.ubuntu.com/ubuntu raring-security multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
# deb http://archive.canonical.com/ubuntu raring partner
# deb-src http://archive.canonical.com/ubuntu raring partner

## This software is not part of Ubuntu, but is offered by third-party
## developers who want to ship their latest software.
deb http://extras.ubuntu.com/ubuntu raring main
share|improve this question
    
How did you install Rhythmbox 2.98? –  Mitch May 7 '13 at 18:10
1  
Ubuntu 13.04 is shipped with Rhythmbox 2.98 –  VictorL May 7 '13 at 18:15
add comment

3 Answers

up vote 2 down vote accepted

To downgrade any package, you must do two things:

  1. Install the old deb file.
  2. Forbid updating the package to newest versions from repositories.

If you have used the old version, maybe you can find the installed deb file in your /var/cache/apt/archives. If not, try searching the required version on packages.ubuntu.com or other sites. For example, you can try this package: 2.97-1ubuntu6.1.

Then, open file /etc/apt/preferences as root (create the file if it doesn't exist yet) and add the following lines:

Package: rhythmbox
Pin: version 2.97-1ubuntu6.1
Pin-Priority: 1001

(Replace 2.97-1ubuntu6.1 with the exact version you've installed.)

This will force apt-get, aptitude and all such utilities to keep Rhythmbox at this version even when repository has a newer one. If you need to install older versions of some other packages (e.g. rhythmbox-data or maybe some libraries), add similar three lines to the same file, with one line between «paragraphs». You can find some more information about /etc/apt/preferences syntax here.


UPDATE:

I would suggest you to install rhythmbox with all required packages at once with a single console command. I've just tried to do it now, so this is what you need:

  1. Remove your currently installed Rhythmbox (if this is not possible due to other dependencies, you may try to skip this step and ignore some warnings later).
  2. Download packages from quantal: rhythmbox_2.97-1ubuntu5, libmusicbrainz5-0, librhythmbox-core6, rhythmbox-data, gir1.2-rb-3.0. Put them all in a single directory.
  3. Open terminal, cd to the directory and run sudo dpkg -i *.deb. This should install the old Rhythmbox.

After that, just look which updates do you have in Synaptic or elsewhere, and add those packages to /etc/apt/preferences as I've wrote above.

share|improve this answer
    
dpkg: dependency problems prevent configuration of rhythmbox: rhythmbox depends on libmusicbrainz5-0; however: Package libmusicbrainz5-0 is not installed. rhythmbox depends on librhythmbox-core6 (= 2.97-1ubuntu6.1); however: Version of librhythmbox-core6 on system is 2.98-0ubuntu5. rhythmbox depends on rhythmbox-data (= 2.97-1ubuntu6.1); however: Version of rhythmbox-data on system is 2.98-0ubuntu5. rhythmbox depends on gir1.2-rb-3.0 (= 2.97-1ubuntu6.1); however: Version of gir1.2-rb-3.0 on system is 2.98-0ubuntu5. Can't force version in Synaptic for these packages –  VictorL May 8 '13 at 10:01
    
Yes, your system can't resolve dependencies because the required packages are not in current repositories but in quantal. I've updated my answer to explain where to get them manually. (Alternatively, you can add quantal repositories to sources.list, but I'm not sure if it is a problem-free solution.) –  Maaaks May 9 '13 at 7:40
    
Works like a charm, thanks for helping me !! –  VictorL May 9 '13 at 12:53
    
I still get dependency problems: dpkg: error processing rhythmbox (--install): dependency problems - leaving unconfigured –  duxk.gh Jun 11 '13 at 18:54
    
I think you should try to view rhythmbox's dependencies, for example, in Synaptic and try to upgrade them manually. It will help you find out which dependency can't be upgraded and why. AFAIR, sometimes this problem can be caused by a change in package's dependencies, when package manager needs to remove a previously neccessary aux package, and it doesn't want to do it without your confirmation. But I'm very unsure. :-( –  Maaaks Jun 12 '13 at 5:55
show 1 more comment

To downgrade from 2.98:

sudo apt-get purge rhythmbox gir1.2-rb-3.0 librhythmbox-core5 rhythmbox-mozilla rhythmbox-data rhythmbox-plugin-zeitgeist rhythmbox-plugin-magnatune rhythmbox-plugin-cdrecorder librhythmbox-core6 rhythmbox-plugins

i.e. the ppa-purge does not clean-up fully and leaves some libraries still at their v2.98 versions.

Finish off by updating your sources:

sudo apt-get update && sudo apt-get upgrade

And install an old version of rhytmbox:

sudo add-apt-repository ppa:fossfreedom/rhythmbox
sudo apt-get update && sudo apt-get install rhythmbox

This will leave you with the default and stable Rhythmbox 2.97.

share|improve this answer
    
Didn't work, I had no ppa:webupd8team/rhythmbox After update && upgrade I do : sudo apt-get install -y rhythmbox And I get 2.98 –  VictorL May 7 '13 at 18:27
    
@VictorL Sorry, I just eddited my answer. –  Radu Rădeanu May 7 '13 at 18:49
1  
W: Impossible de récupérer http://ppa.launchpad.net/fossfreedom/rhythmbox/ubuntu/dists/raring/main/binary-a‌​md64/Packages 404 Not Found W: Impossible de récupérer http://ppa.launchpad.net/fossfreedom/rhythmbox/ubuntu/dists/raring/main/binary-i‌​386/Packages 404 Not Found Unfortunately this PPA does not support raring :( –  VictorL May 7 '13 at 18:58
    
I got the same error; 404 not found. No Raring support (yet). –  duxk.gh May 7 '13 at 19:05
    
You should modify in Software & Updates > Other software from raring to precise distribution. –  Radu Rădeanu May 7 '13 at 19:05
show 1 more comment

Have a look at this thread for downgrading: http://www.howtogeek.com/117929/how-to-downgrade-packages-on-ubuntu/

share|improve this answer
    
This doesn't work for Rhythmbox; Force Version isn't clickable. –  duxk.gh May 7 '13 at 19:18
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.