Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm having some difficulty with Steam. I installed the proprietary driver using Additional Drivers, and up until now, thought it had installed correctly. All my desktop effects worked flawlessly.

But, when I tried to run steam, it said, "OpenGL GLX context is not using direct rendering, which may cause performance problems".

So, I thought that perhaps I hadn't installed the driver yet. Opening Additional drivers, it shows Nvidia 3.10, but says that "This driver has been actived, but is not in use" Trying to launch Portal, is says it couldn't find the "required entry point 'gelGetError'".

So, as far as I can tell, Steam thinks that I don't have the propietary driver installed. But, when I open Nvida X Server settings, it clearly says I have driver 3.10.

Can anyone please tell me what's going?

EDIT: Sorry for taking so long to respond, as requested, here is the result of running "lsmod | grep nv"

     nvidia     9410995  52
share|improve this question
    
Try re-installing and driver, you probably have a mis-match between Xorg drive and GLX versions. With X running also add the content of lsmod | grep nv to you post. –  coteyr May 7 '13 at 16:41
add comment

3 Answers 3

edit your /etc/modprobe.conf, and add the following:

install nvidia

it should work then

share|improve this answer
    
My system doesn't have a /etc/modprobe.conf file. It does have a /etc/modprobe.d/ folder, though. But inside it is several conf files. Should I edit anything there? –  StephanG May 10 '13 at 19:02
add comment

I had the same issue, though with an AMD card What fixed it for me was this:

sudo usermod -a -G video <username>

and then rebooting.

Explanation

Per default the user is not allowed to use direct write because he is not member of the video group

share|improve this answer
    
Already tried this, it didn't help. –  StephanG May 10 '13 at 18:59
add comment

after you install the Nvidia driver,make sure you have the nvidia-current package installed, it is the main package for the driver and without it your driver won't work.

thanks.

share|improve this answer
    
I installed nvidia-current, and it removed the 3.10 driver, and installed 3.04. Regardless, it doesn't seem to make a difference. –  StephanG May 10 '13 at 19:00
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.