it is my first time here in this forum. I am trying to upgrade this ubuntu system to the next LTS version and i am encountering some problems in order to upgrade.
cristina@cristina:~$ sudo apt-get -f install Reading package lists ... done Building dependency tree Reading state information ... done Correcting dependencies ... failed. The following packages have unmet dependencies: libc6: Depends: libc-bin (= 2.11.1-0ubuntu7.10) but 2.15-0ubuntu10.2 is installed Recommends: libc6-i686 python-louis: Depends: liblouis0 (> = 1.7.0-2) but it is not installable ubuntu-minimal: Depends: libc6-i686 E: Error, pkgProblemResolver :: Resolve generated breaks, this may be caused by held packages. E: Unable to correct dependencies
If i try it with synaptic, the tool gives me 3 broken packages:
libc6, python-louis and ubuntu-minimal.
I cannot upgrade this packages using synaptic or doing a apt-get -f install and in the meanwhile i cannot upgrade the system. I cannot upgrade the system with a fresh install.
cristina@cristina:~$ cat /etc/lsb-release DISTRIB_ID=Ubuntu DISTRIB_RELEASE=10.04 DISTRIB_CODENAME=lucid DISTRIB_DESCRIPTION="Ubuntu 10.04.4 LTS"