Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

it is my first time here in this forum. I am trying to upgrade this ubuntu system to the next LTS version and i am encountering some problems in order to upgrade.

cristina@cristina:~$ sudo apt-get -f install
Reading package lists ... done
Building dependency tree
Reading state information ... done
Correcting dependencies ... failed.
The following packages have unmet dependencies:
   libc6: Depends: libc-bin (= 2.11.1-0ubuntu7.10) but 2.15-0ubuntu10.2 is installed
          Recommends: libc6-i686
   python-louis: Depends: liblouis0 (> = 1.7.0-2) but it is not installable
   ubuntu-minimal: Depends: libc6-i686
E: Error, pkgProblemResolver :: Resolve generated breaks, this may be caused by held packages.
E: Unable to correct dependencies

If i try it with synaptic, the tool gives me 3 broken packages:

libc6, python-louis and ubuntu-minimal.

I cannot upgrade this packages using synaptic or doing a apt-get -f install and in the meanwhile i cannot upgrade the system. I cannot upgrade the system with a fresh install.

cristina@cristina:~$ cat /etc/lsb-release 
share|improve this question
have you tried sudo apt-get dist-upgrade and if you could post your /etc/apt/sources.list file – GM-Script-Writer-62850 May 7 '13 at 15:34

Better use Livecd install it will be faster, go smooth and with no issues, ending with good working OS.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.