Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have already installed MySQL workbench from the Software Center on a recent installation of Ubuntu 12.10 (32 bit) with no problems. Since then, I just installed ubuntu 12.04 LTS on another machine (64 bit) and I can't find it in the software center.

Is there a way I can enable the repositories to make it available to me? I know it exists for 12.10 so I am assuming it is available for 12.04.

Thanks for any input!


I switch my server in the software sources GUI (from Ubuntu Software Center go to Edit -> Software Sources..)

I was set to the Spain server (since I am in Spain) and I switched it to the Main Server, then did apt-get update and i was able to install with apt-get after that.

share|improve this question
add comment

3 Answers 3

In precise (12.04), quantal (12.10), and raring (13.04), the mysql-workbench package is in universe, so:

  1. Open the "Software Sources" app, a.k.a. software-properties-gtk
  2. Ensure the "Community maintained free and open-source software" checkbox is checked
  3. Refresh your packages, either through a Refresh button or through sudo apt-get update
  4. Install it via your favorite package management app, or sudo apt-get install mysql-workbench
share|improve this answer
1 & 2 both are currently like that. output from apt-get install mysql-workbench: unable to locate package mysql-workbench –  jeffery_the_wind May 7 '13 at 15:27
Weird oÔ. Well, @TheLordOfTime's answer does the job! –  Ronan Jouchet May 7 '13 at 15:29
i switch my server in the above mentioned software sources GUI. I was set to the Spain server (since I am in Spain) and I switched it to the Main Server, then did apt-get update and i was able to install with apt-get after that. –  jeffery_the_wind May 7 '13 at 15:29
@jeffery_the_wind what likely was the problem is that you didn't actually apt-get update after enabling universe, which threw the initial issues. Glad to see this fixed it though. –  Thomas W. May 7 '13 at 15:48
@TheLordofTime Thanks for the help. Universe repos were enabled the whole time. I just checked to make sure all the check boxes were there, so actually I think it was the server issue. –  jeffery_the_wind May 8 '13 at 11:01
add comment

MySQL Workbench might not be in the repositories for 12.04.

However, you can download and install a .deb from Oracle, here, just make sure you choose the correct debian package under "Ubuntu Linux" option for the operating systems.

share|improve this answer
It is wrong. I installed it from repositories on my 12.04 –  shgnInc Oct 14 '13 at 15:58
add comment

Install MySQL Workbench on Ubuntu 12.04

Here's a link that will get you started.

share|improve this answer
Welcome to Ask Ubuntu! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. –  Thomas W. May 7 '13 at 15:46
add comment

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.