Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I checked How do I disable mouse magnet on middle edge with multi monitors? but it doesn't work for me.

I have two monitor and want to disable the edge resistance and sticky to the edges in Ubuntu 13.04.

I set Sticky Edges to OFF in Displays.

With CompizConfig I set:

  • overcome_pressure=1
  • Edge stop velocity=1
  • Duration of Sticky Edge realease=1

I also disabled Snapping Windows.

Even so, I'm still feeling resistance when moving between monitors. Also, the windows are attracted to the edges when I move closer.

Could this be a bug or there are more steps I need to configure to disable such behaviours?

edge_stop_velocity=20

share|improve this question
1  
so... where in CompizConfig did you find those settings?? – drevicko Aug 9 '13 at 0:38

Writing up an answer filling in some of the gaps in OP's steps.

First you probably want to follow the steps in this related question. The first did not work for me on Ubuntu 14.04, but these seem to have.

Where do I find a setting in CompizConfig Manager?

Advanced Search > Settings value will solve this.

overcome_pressure is in Ubuntu Unity Plugin. Set to 1.
Edge Stop Velocity is in Ubuntu Unity Plugin. Set to 1.
Duration of Sticky Edge Release after Break is in Ubuntu Unity Plugin. Set to 1.

Lastly follow Workarounds > Window Stickiness and remove Any.

share|improve this answer
    
Holy crap this actually worked. Thanks. The accepted answer does nothing. This should be the accept answer. – Cerin Apr 29 '15 at 19:01
up vote 0 down vote accepted

The problem lies in the Workarounds compiz plugins.

Besides all the normal steps, described in my question, you need to remove Workarounds\Windows stickness\Any

share|improve this answer

One solution is to set the external monitor onto the left side of the desktop monitor in System-Settings >> Displays. This changes the direction you slide your mouse into the next screen, but this works when the "Sticky Edge" and CompizConfig-System-Manager options do not.

Drag and drop external monitor to the left side of the main monitor

It appears that the issue with the right side is the placement of the workspace navigator along the right edge of the main monitor. The workaround is to find the sweet spots above and below the navigator but that can be rather annoying to rely upon.

NOTE: Applying this change to the left side of the monitor relinquishes any left-screen edge mouse controls such as the system search bar and the applications sidebar. However you still can access it via the "Super" button. But if you're using Gnome-Do or if you're a terminal wiz, this shouldn't be much of an issue.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.