Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When I run the installation from a Bootable DVD, I am given the choice to install alongside Windows 7. I click Continue to select this option. I leave the partition sizes as recommended 100.6GB on the left and 93.GB5 on the right. I click install now.

I get:

Error an error occurred whilst writing the changes to the storage devices. The resize operation has been aborted!

What's the best course of action?

sudo fdisk -l

Disk /dev/sda: 250.1 GB, 250059350016 bytes
255 heads, 63 sectors/track, 30401 cylinders, total 488397168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x307a923b

Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *        2048      206847      102400    7  HPFS/NTFS/exFAT
/dev/sda2          206848   488394751   244093952    7  HPFS/NTFS/exFAT

Disk /dev/sdb: 200.0 GB, 200049647616 bytes
255 heads, 63 sectors/track, 24321 cylinders, total 390721968 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x63a6579d

Device Boot      Start         End      Blocks   Id  System
/dev/sdb1              63        2047         992+  42  SFS
/dev/sdb2            2048    11573247     5785600   27  Hidden NTFS WinRE
/dev/sdb3        11573248   390719919   189573336   42  SFS

I fixed this problem by entering the Advanced section of the install and creating free space by deleting the area where I wanted to install Ubuntu.

share|improve this question
Boot up from LiveCD and open terminal, type sudo fdisk -l, and add the output here. – Mitch May 7 '13 at 11:03
The suggestion below doesn't work so I'll try your method – SimplySimon May 7 '13 at 11:13
Hmmm! I can't stay logged in to the website in Firefox on Ubuntu so I'll give you a run down on what is on the screen: I'll post it in a new comment below. – SimplySimon May 7 '13 at 11:28
I have added it to the original question – SimplySimon May 7 '13 at 11:43
Do you want Ubuntu to use the 200.0 Drive /dev/sdb – Mitch May 7 '13 at 12:34

I read somewhere that there is a 1 MB issue in the ubuntu installer...i.e You need to select 1MB more in the partition than what it currently has, and the same size would be selected (no resize needed)

e.g: 512 MB current partition, while reinstalling, select 513 would pick up as 512 MB and would use the current partition untouched.

share|improve this answer
I tried this and it didn't work :[ – SimplySimon May 7 '13 at 11:14
Try GParted instead to partition. The standards Ubuntu installer uses make rounding to cylinder and 1MB=1000KB instead of 1024 and the same for GB and TB, which could create issues with partitioning. – Jack Mayerz May 7 '13 at 11:58
I'll try this next if other suggestions don't work. – SimplySimon May 7 '13 at 12:23

Before installing I recommend you to set up an area of "unallocated space" on the hard drive. You can do that from Win7 by resizing the partition on the disk you wish to install Ubuntu. I wouldn't recommend doing it during the install. Then during the install you can select that "unallocted space" for the Ubuntu installation (or ubuntu does it on its own if you select the first options "install alongside Windows 7"). This is how I usually do it. Its safest.

share|improve this answer
Thanks for this. I have just delegated an empty partition, but the same thing happens. Now I'm about to add a screen shot of sudo fdisk -l to show people what's on offer to me. – SimplySimon May 7 '13 at 11:19
You said empty partition. What sort of partition is it? FAT32? – ubuntujeev May 7 '13 at 11:22
It was a NFTS partition. – SimplySimon May 7 '13 at 11:41
Actually it should not be NTFS, delete the partition and leave the space unallocated, no NTFS, no FAT32 nothing – ubuntujeev May 7 '13 at 12:13
Thanks, I tried this, unfortunately, with the same results. – SimplySimon May 7 '13 at 12:21

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.