Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a Samsung RF510 laptop computer. Upon installing Ubuntu 10.10 onto it I could not get the trackpad to function properly. It works as a basic mouse (point and click) but had no functionality for edge scrolling or any of the multitouch settings the trackpad is capable of.

I discovered the reason is a known issue where the Ubuntu kernel will improperly detect an Elantech trackpad as a logitech PS/2 wheel mouse, and as such will gain none of the functionality that seems to be coded for synaptics trackpads.

Is there any way to get this working properly? I would like basic scrolling/zooming/etc I've been used to using these features for as long as I can remember.

share|improve this question
I had a similar problem on my asus. This worked for me:… (afterwards, "sudo rmmod psmouse && sudo modprobe psmouse") Note that I don't actually understand what this does and I don't know how to reverse it, so tread carefully. – aureianimus Aug 28 '11 at 12:24

If you're able to upgrade to Ubuntu 11.10, that already has built-in support for your touchpad in the kernel.

share|improve this answer
Not working out of the box in 13.04. – Case Jun 10 '13 at 6:43

The method found here works for me:

sudo apt-get install dkms
cd /usr/src/
sudo wget
sudo tar jxvf psmouse-elantech-v6.tar.bz2
sudo dkms add -m psmouse -v elantech-v6
sudo dkms build -m psmouse -v elantech-v6
sudo dkms install -m psmouse -v elantech-v6
share|improve this answer
This doesn't compile by default, but after adding the extra option that is now required to a line in elantech.c, it still doesn't work...xinput still indicates the touchpad registering as a mouse. – Case Jun 10 '13 at 6:43

While this doesn't fix the problem you're having, it does fix all the other problems that exist with the RF510. Things such as the backlight and function keys. He did address the touchpad problem, but doesn't know of a fix at the moment.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.