Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After upgrading to quantal, I wanted to install wine. However, attempting to do so results in apt wanting to remove all kinds of important packages:

The following packages will be REMOVED:
  libgl1-mesa-dri-lts-quantal libgl1-mesa-glx-lts-quantal libglapi-mesa-lts-quantal xserver-xorg-core-lts-quantal
  xserver-xorg-input-evdev-lts-quantal xserver-xorg-lts-quantal

I have done extensive searching on the subject.

This thread describes my problem exactly . I tried the suggested solution (to give quantal release the highest pin), and while a few packages were downgraded, I am still unable to install wine.

This thread seems similar, however my apt is aware of foreign architecture:

$ sudo dpkg --print-architecture
amd64
$ sudo dpkg --print-foreign-architectures
i386

I read about resolving unmet dependencies, and did sudo apt-get autoclean (which removed a bunch of stuff, presumably leftover from pangolin), sudo apt-get clean (which didn't seem to remove anything), and the sudo apt-get -f install plus sudo dpkg --configure -a back and forth, which showed there was still a problem:

0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.

So following that same thread again, running sudo apt-get -o Debug::pkgProblemResolver=yes dist-upgrade produces:

Broken xorg:amd64 Depends on xserver-xorg [ amd64 ] < none -> 1:7.7+1ubuntu4 > ( x11 ) (>= 1:7.7+1ubuntu4)
  Considering xserver-xorg:amd64 4 as a solution to xorg:amd64 1
  Holding Back xorg:amd64 rather than change xserver-xorg:amd64
 Try to Re-Instate (1) xorg:amd64

I can't find any way to fix this issue, and I'm scared to experiment with such important libraries.

Finally, I found this bug report that seems to describe my problem, but the patch that resolves it is only uploaded to pangolin, so I don't think using apt from the quantal proposed source will help me.

If anyone has any advice, I'd be so happy to hear about it! I've been spending many hours on this problem and not getting anywhere...

Thanks very much in advance!


Responses to questions:

Question 1:

please can you pastebin.com the output of sudo apt-get update && sudo apt-get upgrade && sudo apt-get dist-upgrade BEFORE you try to install wine. These commands ensure your repositories are fully up-to-date.

Also - do you have any PPAs such as x-swat or x-edgers installed?

Answer 1:

Thanks for the comments! The result of the update and upgrade commands shows xorg is held back. I don't have any PPAs.

Question 2:

So what is the output if you do sudo apt-get install xorg ?

Answer 2:

The output says I have unmet dependencies xserver-xorg (>= 1:7.7+1ubuntu4). If I run the same command with debugging on, I get a lot of information, but it doesn't really make sense to me. For example, it says Fixing libgl1-mesa-dri-lts-quantal:amd64 via keep of libgl1-mesa-dri:amd64, yet if I check dpkg --get-selections, I have only libgl1-mesa-glx-lts-quantal:amd64 not the libgl1-mesa-dri:amd64 that it looks like it wants to keep.

For completeness, I've posted my sources.list as well.

share|improve this question
1  
how much hard drive space you have left? have you considered creating a new partition of about 10GB, and make a clean 64bit (that is truly worth it) install of 12.10 (or even 13.10) on it? Then, after that, you can simply symlink your new home folder to the old one in the old partition. If you want to go safer, make a copy of your old home folder but it may not fit on the new 10GB partition, so you can simply make a copy of it to somewhere else and symlink it! –  Aquarius Power May 11 '13 at 15:21
1  
Later on, using a live CD or bootable pendrive or loop image, you can copy your new 10GB partition to the old partition overwriting it (so your new partition is still bootable), and expand it to the remaining size of the old partition. Leave always 10GB for a new install. I have bad experiences too on upgrading so I dont loose time trying it UNLESS I have made a backup of my partition first! –  Aquarius Power May 11 '13 at 15:25
    
I had been hoping to avoid doing a fresh install, but I'll call this plan B. I don't have much in this install, so I should be able to just copy my home dir to a windows partition, erase the ubuntu partition, do a clean install, and then copy it back, right? –  Corey May 11 '13 at 18:28
    
beware! windows partition wont have linux files permissions etc... Or create a small partition on the free space and format it to ext3, or make a .tar.gz with your files (and if it is small, duplicate the file for security). –  Aquarius Power May 12 '13 at 21:49

2 Answers 2

up vote 1 down vote accepted

Thanks to your effort and fullness of information in your post, the question is easy to answer. Those packages with their name ending with "lts-quantal" are Precise packages (despite their name) left installed by the dist-upgrade. You don't need those packages, moreover, they are in your way of properly maintain and upgrade your system. Simply install wine and let apt remove those unneeded packages. Doing so will solve the xorg package conflicts as well.

share|improve this answer
1  
Well, that was easy! –  Corey May 18 '13 at 22:36

I just remembered, if you havent made a fresh install yet, try PlayOnLinux first!

check this

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.