Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I am trying to share any folder , following error comes in the screen :

Samba's testparm returned error 1: Load smb config files from /etc/samba/smb.conf
rlimit_max: increasing rlimit_max (1024) to minimum Windows limit (16384)
Processing section "[printers]"
Processing section "[print$]"
Loaded services file OK.
WARNING: 'workgroup' and 'netbios name' must differ.

How to resolve this kind of problem ?

share|improve this question

1 Answer 1

up vote 0 down vote accepted

WARNING: 'workgroup' and 'netbios name' must differ.

As the error message tells you: change either the workgroup or the netbios name so they are different (ie. unique!). And it also tells you where to do this: /etc/samba/smb.conf.

See the section [global] in /etc/samba/smb.conf.

It will have 2 options named...

netbios name =
workgroup = 

These need to be different. If they are empty the get defaulted. See for both these snippets from the Samba manual:

netbios name

The default value for this configuration option is the server's hostname—that is, the first part of its fully qualified domain name.

Changing the NetBIOS name of the server is not recommended unless you have a good reason. One such reason might be if the hostname of the system is not unique because the LAN is divided over two or more DNS domains. For example, YORKVM1 is a good NetBIOS candidate for vm1.york.example.com to differentiate it from vm1.falkirk.example.com, which has the same hostname but resides in a different DNS domain.

Source.


workgroup

The workgroup parameter sets the current workgroup (or domain) in which the Samba server will advertise itself. Clients that wish to access shares on the Samba server should be in the same NetBIOS group. Remember that workgroups are really just NetBIOS group names and must follow the standard NetBIOS naming conventions outlined in Chapter 1.

The default option for this parameter is set at compile time to WORKGROUP. Because this is the default workgroup name of every unconfigured Windows and Samba system, we recommend that you always set your workgroup name in the Samba configuration file. When choosing your workgroup name, try to avoid making it the same name as a server or user. This will avoid possible problems with WINS name resolution.

Source.


rlimit_max: increasing rlimit_max (1024) to minimum Windows limit (16384)

Add...

* - nofile 16384
root - nofile 16384

to /etc/security/limits.conf and reboot.

It is a warning, you can safely ignore it. Windows 7 clients need to have exactly the same number of open handles available as Windows servers, else it fails in some file copy situations with a "out ofhandles" message. Samba has taken care of it for you, but it's just letting you know your fd limit is set a bit low. Source.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.