Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I had a 200GBS HDD i installed Ubuntu 12.10 over my win vista but it deleted all my windows partitions and data, so I used testdisk from the liveCD and recovered some of the important data not all, and I tried to use someone's advice by better recovering them through a windows application so I tried to reinstall windows but I couldn't so I reinstalled Ubuntu again, but this time the file system is showing 186.3GBS only which is also shown at Gparted while the first installation before recovering the files it showed 198GBS capacity, How can I get back this lost space?

P.S.

when I used TestDisk to recover the files, I recovered them (pressing C to copy) to the home folder (/) then I transferred them to my USB stick, could this be the reason for the lost space like a hidden folder or something??

ubuntu@ubuntu:~$ sudo fdisk -l

Disk /dev/sda: 200.0 GB, 200049647616 bytes
255 heads, 63 sectors/track, 24321 cylinders, 

total 390721968 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size 

(minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x0006b252

   Device Boot      Start         End      Blocks   Id  

System
/dev/sda1   *        2048   143362047    71680000    7  HPFS/NTFS/exFAT
/dev/sda2       143364064   229086899    

42861418    7  HPFS/NTFS/exFAT
/dev/sda3       229086905   390716864    80814980    f  W95 Ext'd (LBA)
/dev/sda5       

229086968   321251804    46082418+   7  HPFS/NTFS/exFAT
/dev/sda6       321251868   390716864    34732498+   7  

HPFS/NTFS/exFAT

Disk /dev/sdb: 4022 MB, 4022337024 bytes
255 heads, 63 sectors/track, 489 cylinders, total 7856127 

sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size 

(minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x68626862

   Device Boot      Start         End      Blocks   Id  

System
/dev/sdb1   *          38     7839719     3919841    b  W95 FAT32

share|improve this question
1  
I edited the post with the output of sudo fdisk -l but I am not allowed to post any images :( , I installed Windows 7 and used EaseUs partition recovery and recovered most of the data but to my surprise windows also showed the same results of Gparted, can wiping the whole disk can recover the lost space? –  Niky885 May 7 '13 at 18:57

1 Answer 1

up vote 0 down vote accepted

Your drive and your partitions are perfectly fine. I am unable to see an issue here.

It may be possible that from re-partitioning and from recovering partitions with testdisk some partitions can not be recovered completely. This may then lead to unused, or badly allocated hard drive space, but this is not the case in your present partition layout.

We have here an issue with different units used for your storage quantity:

1 GB  = 1.000.000.000 bytes  
1 GiB = 1.073.741.824 bytes

for your drive this means a capacity of

200 GB                   = 200.049.647.616 bytes (as correctly displayed from fdisk)  
186,31 GiB × 1,073741824 = 200.048.839.229 bytes.

The missing few bytes are likely a rounding error.

share|improve this answer
    
so does this mean that I can have a full usage of the 200 GBs although it's only showed as 186.31 GBs? it's almost a 15 GBs difference...Isn't there anything that I need to do? –  Niky885 May 8 '13 at 9:15
    
thanks a lot for your help :) –  Niky885 May 10 '13 at 7:44

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.