Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I backed up my home directory with deja-dup, installed Ubuntu 13.04, and attempted to restore the files, but after chosing the date of the backup to restore and chosing the location where to put the files, I get a "Failed with an unknown error" message:

Traceback (most recent call last):
  File "/usr/bin/duplicity", line 1412, in <module>
    with_tempdir(main)
  File "/usr/bin/duplicity", line 1405, in with_tempdir
    fn()
  File "/usr/bin/duplicity", line 1339, in main
    restore(col_stats)
  File "/usr/bin/duplicity", line 630, in restore
    restore_get_patched_rop_iter(col_stats)):
  File "/usr/lib/python2.7/dist-packages/duplicity/patchdir.py", line 522, in     Write_ROPaths
    for ropath in rop_iter:
  File "/usr/lib/python2.7/dist-packages/duplicity/patchdir.py", line 495, in integrate_patch_iters
final_ropath = patch_seq2ropath( normalize_ps( patch_seq ) )
  File "/usr/lib/python2.7/dist-packages/duplicity/patchdir.py", line 475, in patch_seq2ropath
    misc.copyfileobj( current_file, tempfp )
  File "/usr/lib/python2.7/dist-packages/duplicity/misc.py", line 166, in copyfileobj
    buf = infp.read(blocksize)
  File "/usr/lib/python2.7/dist-packages/duplicity/librsync.py", line 80, in read
self._add_to_outbuf_once()
  File "/usr/lib/python2.7/dist-packages/duplicity/librsync.py", line 94, in _add_to_outbuf_once
raise librsyncError(str(e))
librsyncError: librsync error 103 while in patch cycle

I tried to restore earlier backup points, but all of them fail. I installed Ubuntu 12.10 again and tried to restore from there (to have the same version of deja-dup etc.), same problem. Any ideas how I could rescue my data? By now, I'm pretty desperate.

share|improve this question
    
I have the same problem. Have you solved it by now? –  isphording90 Sep 6 '13 at 11:38

1 Answer 1

Possibly you are not selecting correct folder (as I was). Try>> Is it possible to restore only one directory with the backup utility?

Apparently the "/home " directory is not possible in deja dup but the /home/user is available.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.