Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After installing evolution-mapi in Ubuntu 13.04, I am getting this error

(evolution:8018): camel-CRITICAL **: camel_provider_list: Could not load /usr/lib/evolution-data-server/camel-providers/libcamelmapi.so: libdbwrap.so: cannot open shared object file: No such file or directory

And Evolution Mapi does not show up in the list of providers when setting up emails. How do I resolve this?

my list of installed evolution packages are :

tux01:~/Downloads$ sudo dpkg-query -l | grep evolution*

ii evolution 3.6.4-0ubuntu1

ii evolution-common 3.6.4-0ubuntu1

ii evolution-data-server 3.6.4-0ubuntu1

ii evolution-data-server-common 3.6.4-0ubuntu1

ii evolution-indicator 0.2.20-0ubuntu10

ii evolution-mapi 3.6.2-0ubuntu1

ii evolution-plugins 3.6.4-0ubuntu1

share|improve this question
add comment

2 Answers

up vote 8 down vote accepted

The package python-samba installs the missing lib file. However once I got past that issue, Evolution won't save my account info for my newly created Exchange account. Curious if you experience the same thing.

EDIT: Had to kill all evolution related processes. Then two attempts I made at setting up my exchange account showed up as two accounts in Evolution. Removed one and everything seems to be working fine.

share|improve this answer
    
Thanks. That enabled MAPI. However, I think our server is behind the proxy, which is not supported yet. So I am out of luck! –  Ubuntuser May 8 '13 at 6:37
    
Worked perfectly after pulling my hair out for a while. This dependency needs to be fixed. –  chawkinsuf May 20 '13 at 17:11
    
I also could not create an account. Killed the processes and they showed up! I also had to kill the processes a second time to get my account's folders to show up. All is well since then. –  Ethereal Dec 31 '13 at 17:16
add comment

you need to at least log out and login again to see the new accounts, you will need to restart for the calendar to start working. at least thats what i had to do on 12.10.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.