Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am getting the following error when installing "qtbase" package for R:

[ 68%] Building CXX object smoke/qt/CMakeFiles/smokeqt.dir/x_1.cpp.o
/home/mroot/qtbase/kdebindings-build/smoke/qt/x_1.cpp: In static member function ‘static void __smokeqt::x_QAbstractPrintDialog::x_8(Smoke::StackItem*)’:
/home/mroot/qtbase/kdebindings-build/smoke/qt/x_1.cpp:4893: error: cannot allocate an object of abstract type ‘__smokeqt::x_QAbstractPrintDialog’
/home/mroot/qtbase/kdebindings-build/smoke/qt/x_1.cpp:4834: note:   because the following virtual functions are pure within ‘__smokeqt::x_QAbstractPrintDialog’:
/usr/include/qt4/QtGui/qabstractprintdialog.h:89: note:     virtual int QAbstractPrintDialog::exec()
/home/mroot/qtbase/kdebindings-build/smoke/qt/x_1.cpp: In constructor ‘__smokeqt::x_QAbstractPrintDialog::x_QAbstractPrintDialog()’:
/home/mroot/qtbase/kdebindings-build/smoke/qt/x_1.cpp:4896: error: no matching function for call to ‘QAbstractPrintDialog::QAbstractPrintDialog()’
/usr/include/qt4/QtGui/qabstractprintdialog.h:116: note: candidates are: QAbstractPrintDialog::QAbstractPrintDialog(const QAbstractPrintDialog&)
/usr/include/qt4/QtGui/qabstractprintdialog.h:113: note:                 QAbstractPrintDialog::QAbstractPrintDialog(QAbstractPrintDialogPrivate&, QPrinter*, QWidget*)
/usr/include/qt4/QtGui/qabstractprintdialog.h:86: note:                 QAbstractPrintDialog::QAbstractPrintDialog(QPrinter*, QWidget*)
make[3]: *** [smoke/qt/CMakeFiles/smokeqt.dir/x_1.cpp.o] Error 1
make[3]: Leaving directory `/home/mroot/qtbase/kdebindings-build'
make[2]: *** [smoke/qt/CMakeFiles/smokeqt.dir/all] Error 2
make[2]: Leaving directory `/home/mroot/qtbase/kdebindings-build'
make[1]: *** [all] Error 2
make[1]: Leaving directory `/home/mroot/qtbase/kdebindings-build'
make: *** [all] Error 2
ERROR: compilation failed for package ‘qtbase’
* removing ‘/home/mroot/R/i686-pc-linux-gnu-library/2.12/qtbase’

Any ideas?

share|improve this question

migrated from stackoverflow.com Mar 5 '11 at 22:51

This question came from our site for professional and enthusiast programmers.

closed as too localized by desgua, jrg Feb 24 '12 at 0:09

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

1  
At a minimum, more information on your OS and version of R, qt, C++, etc. are needed. –  gsk3 Mar 5 '11 at 13:14
1  
@gsk3 OS:Ubuntu 10.10, R:2.12.2, qt:4.7, C++(gcc):4.4.5 –  teucer Mar 5 '11 at 13:22
    
Have you tried installing a previous version of qtbase? Sometimes Ubuntu packages just are too up-to-date for their own good, and this looks like it might be one of those cases. –  gsk3 Mar 5 '11 at 14:10
    
This question appears to be abandoned, if you are experiencing a similar issue please ask a new question with details pertaining to your problem. If you feel this question is not abandoned, please flag the question explaining that. :) –  jrg Feb 24 '12 at 0:09

1 Answer 1

Do you have libqt4-dev installed?

For what it is worth, I can install the current git checkout of qtbase without a problem on Ubuntu 10.10.

share|improve this answer
    
@Dirk Eddelbuettel yes. I have followed the instructions... –  teucer Mar 5 '11 at 19:50
    
Then I pass---as I said, it worked flawlessly for me for qtbase, qtpaint, qtutils and mosaiq. –  Dirk Eddelbuettel Mar 5 '11 at 20:14