Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to install Ubuntu 12.04 to run in VirtualBox alongside my Win7 64bit OS, without having to dual-boot.

I added the 64-bit Ubuntu iso to my VM, and powered it up so to proceed with the installation, but it prompted me with this error:

This kernel requires an x86-64 CPU, but only detected an i686 CPU. Unable to boot - please use a kernel appropriate for your CPU.

Why does it give me this error, seeing as I have a 64bit processor? Is there a way that I can run Ubuntu via my VM in the first place?

share|improve this question

marked as duplicate by minerz029, karel, Avinash Raj, Eric Carvalho, BuZZ-dEE Jan 8 '14 at 11:18

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1  
The Ubuntu in the VM is looking at a virtual CPU. You have to change the setting in VirtualBox when you create the VM. – user68186 May 6 '13 at 20:18
up vote 2 down vote accepted

When creating a VM using VirtualBox, the first screen you are presented with asks for the name of your new VM and attempts to auto-detect which operating system you're installing. Make sure that you select Ubuntu (64 bit) in the OS drop-down menu. Just selecting Ubuntu in that menu will result in the error you have described.

Screenshot of 64 bit VM selection

share|improve this answer
1  
Thanks for your help; selecting the 64bit version of Ubuntu definitely helped to solve a couple of issues. Now I must enable VT-x/AMD-V in BIOS. Thanks again :) – neo May 6 '13 at 22:08
    
In VirtualBox, those are under (right click on VM)->Settings->System-> Acceleration. Glad I could help. :) – dfarrell07 May 6 '13 at 22:14

Not the answer you're looking for? Browse other questions tagged or ask your own question.