Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

dig @8.8.8.8 google.com

; <<>> DiG 9.9.2-P2 <<>> @8.8.8.8 wp.pl ; (1 server found) ;; global options: +cmd ;; connection timed out; no servers could be reached

but +tcp:

dig @8.8.8.8 google.com +tcp

; <<>> DiG 9.9.2-P2 <<>> @8.8.8.8 google.com +tcp ; (1 server found) ;; global options: +cmd ;; Got answer: ;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 53570 ;; flags: qr rd ra; QUERY: 1, ANSWER: 6, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION: ; EDNS: version: 0, flags:; udp: 512 ;; QUESTION SECTION: ;google.com. IN A

;; ANSWER SECTION: google.com. 300 IN A 173.194.70.139 google.com. 300 IN A 173.194.70.100 google.com. 300 IN A 173.194.70.101 google.com. 300 IN A 173.194.70.113 google.com. 300 IN A 173.194.70.138 google.com. 300 IN A 173.194.70.102

;; Query time: 34 msec ;; SERVER: 8.8.8.8#53(8.8.8.8) ;; WHEN: Mon May 6 21:56:10 2013 ;; MSG SIZE rcvd: 135

so why is dig without +tcp flag refused? Problem with UDP? but 127.0.1.1 works. Is this related to dnsmasq?

It seems like UDP doesn't work from Ubuntu however works on Windows:

dig @8.8.8.8 google.com

; <<>> DiG 9.9.2-P2 <<>> @8.8.8.8 google.com
; (1 server found)
;; global options: +cmd
;; connection timed out; no servers could be reached

WINDOWS

C:\Users\KingOnThisTree>nslookup google.com 8.8.8.8
Serwer:  google-public-dns-a.google.com
Address:  8.8.8.8
Nieautorytatywna odpowiedź:
Nazwa:   google.com
Addresses:  2a00:1450:400f:801::1001
      46.28.247.35
      46.28.247.39
      46.28.247.55
      46.28.247.20
      46.28.247.50
      46.28.247.59
      46.28.247.34
      46.28.247.25
      46.28.247.49
      46.28.247.24
      46.28.247.29
      46.28.247.45
      46.28.247.30
      46.28.247.54
      46.28.247.44
      46.28.247.40
share|improve this question
    
do you have a dns server on localhost? if yes, turn it off and tell us the output of dig @8.8.8.8 google.com –  Hojat Taheri May 6 '13 at 20:09
    
I had a bind installed, I have uninstalled it and now I think I don't have DNS server. I have sendmail and glassfish –  private data public channel 2 May 6 '13 at 21:09
    
@HojatTaheri please see update –  private data public channel 2 May 6 '13 at 23:17
add comment

Know someone who can answer? Share a link to this question via email, Google+, Twitter, or Facebook.

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.