Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently installed Xubuntu and there were a lot of differences I noticed between xfce and gnome. I didn't like Thunar that much (mainly because of the searching feature - even catfish doesn't posses half of the capabilities Nautilus does). So I installed Nautilus and made it the preferred File Manager from exo-preferred-applications. At first everything seemed working - the searching function, places, bookmarks etc. However, I consequently tried copying a file from the Desktop to my home folder and the following error occurred:

And after pressing Skip, another one:

I tried uninstalling thunar and xfdesktop hoping that nautilus would 'take over' the desktop but that didn't happen. Also tried with a symlink for xfdesktop -> nautilus as suggested in some thread but that didn't do the trick either.

The error occurs whenever I try copying or moving something (a file or a folder) from the desktop to another location (by Ctrl+C or Copy from the context menu). Copying and moving works from and to other locations (even from a random location to the desktop but not from it). The strangest part is that when I drag and drop a file or folder from the Desktop to the desired location it works without any errors.

I would be grateful if someone could help me. Thanks in advance!

share|improve this question
    
It's an old post but might help you: Xubuntu with Nautilus. –  Basharat Sialvi May 6 '13 at 20:11
    
Well, I don't know which version of Xfce is this tutorial for, but I can't seem to find almost half of the options and files mentioned. Thanks for the reply, though. Anybody else? –  Abvgz May 7 '13 at 18:52
add comment

1 Answer 1

The article quoted above at Ubuntuforums is a very old discussion and is not really applicable to current Xfce. The following discussion is made up from my experimentation and with reference to the nautilus --no-desktop discussion at the xfce forums.

It depends whether you want to run xfdesktop and nautilus together, or let xfdesktop handle the desktop and use nautilus just as a filemanager. On my 12.04 machine, which has the ppas for xfce 4.10 and 4.12, nautilus seems to work well. However, there are some possibilities if you have problems.

I note you said that you had already made nautilus the default filemanager and removed xfdesktop, but you should be able to run nautilus and xfdesktop in the same session if you use the --no-desktop option when you run nautilus. If you apply any of the commands below, you should logout and then login again to see any changes.


IMPORTANT NOTE: you must find what exactly are your own CLientCommands in your xfce session by launching xfce4-settings-editor and going to the xfce4-session tab and noting which ones currently refer to Thunar and xfdesktop, then modify the number in the commands below accordingly.


Scenario 1) no xfdesktop installed and nautilus is the default filemanager.

You may need to look at your xfce4-session, and alter the failsafe defaults for the Client Commands that define an Xfce session. You also have to do this if you wish to replace the window manager with another one, and I think it might help in this case.

As an example, you could change the Client_Commands that refer to Thunar and xfdesktop to nautilus --no-default-window using xfconf (The --no-default-window option just stops a nautilus window being opened at login).

Remember to use the numbers of the Client_Commands on your own system-see xfce4-settings-editor.

xfconf-query -c xfce4-session -p /sessions/Failsafe/Client2_Command -t string -s "nautilus" -t string -s "--no-default-window" -a
xfconf-query -c xfce4-session -p /sessions/Failsafe/Client3_Command -t string -s "nautilus" -t string -s "--no-default-window" -a

Upon logging in you will get a blank desktop, but you can set a desktop wallpaper by using gnome applications such as gthumb.

This is the best way to ensure that nautilus is running the desktop and nothing else is interfering.

See the end of the article for how to reset them. Logout and login again to see any changes.

Scenario 2) xfdesktop is installed and you wish to use it to manage the desktop and nautilus as a filemanager.

Find the number of your own Client_Command for the filebrowser (Thunar) by refering to the xfce4-session part of xfce4-settings-editor. As an example, my Client_Command was 2, and so this was changed to nautilus --no-desktop --no-default-window.

xfconf-query -c xfce4-session -p /sessions/Failsafe/Client2_Command -t string -s "nautilus" -t string -s "--no-desktop" -t string -s "--no-default-window" -a

Logout and login again to see any changes. Remember to use the numbers of the Client_Commands on your own system-see xfce4-settings-editor.
Whenever you launch nautilus in your session you should use nautilus --no-desktop.

If you need to Reset Changes

Select the appropriate section in xfce-session in the graphical xfce4-settings-editor or use xfconf-query. You must use the actual numbers of the Client_Commands on your own system, not necessarily these ones given in the examples below:

xfconf-query -c xfce4-session -p /sessions/Failsafe/Client2_Command -t string -s "Thunar" -t string -s "--daemon" -a
xfconf-query -c xfce4-session -p /sessions/Failsafe/Client3_Command -t string -s "xfdesktop" -a

Logout and login again to see any changes.

The options suggested above might be useful for you, although very often problems with nautilus on Xubuntu are not always easily solved. The first scenario that makes nautilus manage the desktop and act as filemanager might be most useful, assuming you have made nautilus the default filemanager.

share|improve this answer
    
Well, I tried the commands @Mik suggested but the only thing that happened was that my panels disappeared and the error didn't. Am I supposed to alter my session from the Settings Manager or something else? I tried launching nautilus with nautilus --no-desktop and while in terminal, copied a file from the desktop to another folder and the following error appeared in the terminal: (nautilus:3560): Gtk-WARNING **: Calling Inhibit failed: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.SessionManager was not provided by any .service files –  Abvgz May 8 '13 at 10:33
    
@Abvgz The panels shouldn't disappear. Can you look in xfce4-settings-editor in the xfce-session part and tell me what Client2_Command and CLient3_Command refer to, as they should refer to filemanager and desktopmanager. –  user76204 May 8 '13 at 10:35
    
Um, could you please tell me where exactly are those because I couldn't seem to find them in 'Session and Startup'. –  Abvgz May 8 '13 at 10:37
    
Launch xfce4-settings-editor in terminal and go to xfce4-session, and it will list the session defaults and the Client_Commands. –  user76204 May 8 '13 at 10:39
    
Client2_Command is nautilus --no-default-window and Client3_Command is the same. And by the way, xfce4-panel doesn't autostart when logging in now :( –  Abvgz May 8 '13 at 10:42
show 12 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.