Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have some problem with Ubuntu Software System.

Once I open it up. It closes automatically without any permittion

Can someone help me out please because I dont really get this.

When I run it through terminal this is the feedback I get from the that

vangjush@vangjush:~$ software-center
2013-05-06 21:41:29,532 - - INFO - setting up proxy 'None'
2013-05-06 21:41:29,540 - softwarecenter.db.database - INFO - open() database: path=None use_axi=True use_agent=True
2013-05-06 21:41:30,052 - - WARNING - Could not get usefulness from server, no username in config file
2013-05-06 21:41:30,061 - softwarecenter.fixme - WARNING - logs to the root logger: '('/usr/lib/python2.7/dist-packages/gi/', 51, 'find_module')'
2013-05-06 21:41:30,061 - root - ERROR - Could not find any typelib for LaunchpadIntegration
2013-05-06 21:41:30,217 - - INFO - show_available_packages: search_text is '', app is None.
2013-05-06 21:41:30,555 - softwarecenter.db.pkginfo_impl.aptcache - INFO -
Traceback (most recent call last):
  File "/usr/share/software-center/softwarecenter/db/pkginfo_impl/", line 257, in open
    self._cache = apt.Cache(progress)
  File "/usr/lib/python2.7/dist-packages/apt/", line 102, in __init__
  File "/usr/lib/python2.7/dist-packages/apt/", line 149, in open
SystemError: E:Malformed line 57 in source list /etc/apt/sources.list (dist parse)
2013-05-06 21:41:31,504 - softwarecenter.db.enquire - ERROR - _get_estimate_nr_apps_and_nr_pkgs failed
Traceback (most recent call last):
  File "/usr/share/software-center/softwarecenter/db/", line 115, in _get_estimate_nr_apps_and_nr_pkgs
    tmp_matches = enquire.get_mset(0, len(self.db), None, xfilter)
  File "/usr/share/software-center/softwarecenter/db/", line 89, in __call__
    if (not pkgname in self.cache and
  File "/usr/share/software-center/softwarecenter/db/pkginfo_impl/", line 277, in __contains__
    return self._cache.__contains__(k)
AttributeError: 'NoneType' object has no attribute '__contains__'
Traceback (most recent call last):
  File "/usr/bin/software-center", line 182, in <module>
  File "/usr/share/software-center/softwarecenter/ui/gtk3/", line 1387, in run
  File "/usr/share/software-center/softwarecenter/ui/gtk3/", line 1325, in show_available_packages
  File "/usr/share/software-center/softwarecenter/ui/gtk3/session/", line 151, in set_active_view
  File "/usr/share/software-center/softwarecenter/ui/gtk3/panes/", line 173, in init_view
    self.cache, self.db, self.icons, self.apps_filter)
  File "/usr/share/software-center/softwarecenter/ui/gtk3/views/", line 80, in __init__
  File "/usr/share/software-center/softwarecenter/ui/gtk3/views/", line 324, in build
  File "/usr/share/software-center/softwarecenter/ui/gtk3/views/", line 119, in _build_homepage_view
  File "/usr/share/software-center/softwarecenter/ui/gtk3/views/", line 253, in _append_whats_new
    whats_new_cat = self._update_whats_new_content()
  File "/usr/share/software-center/softwarecenter/ui/gtk3/views/", line 238, in _update_whats_new_content
    docs = whats_new_cat.get_documents(self.db)
  File "/usr/share/software-center/softwarecenter/db/", line 131, in get_documents
  File "/usr/share/software-center/softwarecenter/db/", line 330, in set_query
  File "/usr/share/software-center/softwarecenter/db/", line 225, in _blocking_perform_search
    matches = enquire.get_mset(0, self.limit, None, xfilter)
  File "/usr/share/software-center/softwarecenter/db/", line 89, in __call__
    if (not pkgname in self.cache and
  File "/usr/share/software-center/softwarecenter/db/pkginfo_impl/", line 277, in __contains__
    return self._cache.__contains__(k)
**AttributeError: 'NoneType' object has no attribute '__contains__'**

Whereas when I try to reinstall software system I get this error that stops me the installation.

vangjush@vangjush:~$ sudo apt-get install --reinstall software-center
[sudo] password for vangjush: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
  calligra-l10n-engb camlp4 cdparanoia coq coq-theories coqide k3b k3b-data
  k3b-i18n kde-l10n-engb kde-l10n-zhcn kdevelop-l10n kdevelop-php-docs-l10n
  kdevelop-php-l10n language-pack-kde-en ledit libcoq-ocaml libflac++6 libk3b6
  libkcddb4 liblablgtk2-gnome-ocaml liblablgtk2-ocaml libncurses5-dev
  libtinfo-dev ocaml-base-nox ocaml-interp ocaml-nox
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 1 reinstalled, 0 to remove and 0 not upgraded.
Need to get 628 kB of archives.
After this operation, 0 B of additional disk space will be used.
Get:1 quantal-updates/main software-center all [628 kB]
Fetched 628 kB in 2s (225 kB/s)          
(Reading database ... 287516 files and directories currently installed.)
Preparing to replace software-center (using .../software-center_5.4.1.4_all.deb) ...
Unpacking replacement software-center ...
Processing triggers for bamfdaemon ...
Rebuilding /usr/share/applications/bamf.index...
Processing triggers for desktop-file-utils ...
Processing triggers for gnome-menus ...
Processing triggers for hicolor-icon-theme ...
Processing triggers for man-db ...
Setting up software-center ( ...
Updating software catalog...this may take a moment.
Traceback (most recent call last):
  File "/usr/sbin/update-software-center", line 170, in <module>
    result = rebuild_database(pathname)
  File "/usr/share/software-center/softwarecenter/db/", line 1109, in rebuild_database
  File "/usr/share/software-center/softwarecenter/db/pkginfo_impl/", line 257, in open
    self._cache = apt.Cache(progress)
  File "/usr/lib/python2.7/dist-packages/apt/", line 102, in __init__
  File "/usr/lib/python2.7/dist-packages/apt/", line 149, in open
**SystemError: E:Malformed line 57 in source list /etc/apt/sources.list (dist parse)**

Thank you in advance.

share|improve this question
you can try to run software-center in the terminal, it might give some information why the app shuts down. If you cannot solve it yourselves paste the output in your post. – Wouter May 6 '13 at 19:27
@Wouter:The problem is that I dont get any output. It just closes without any notification. – Morfeos May 6 '13 at 19:40
thats why I suggest to run it in a terminal sometimes that will give error messages that are not shown when you just start the app normally.. – Wouter May 6 '13 at 19:47
@ Wouter. thank you a lot but even though I run it from the terminal still I cannot find the bug. I just posted the error on my comment. – Morfeos May 6 '13 at 19:51
I think the last line is the error message, I fount this question with the same error, have a look at that – Wouter May 6 '13 at 19:57
up vote 0 down vote accepted

I had almost exacly the same issue. Debug output:

2013-05-07 22:00:43,106 - root - ERROR - Could not find any typelib for LaunchpadIntegration
2013-05-07 22:00:43,106 - - DEBUG - launchpad integration error: 'cannot import name LaunchpadIntegration' ..."
Reason : Open "".

Fix : I tried '.. remove --purge ..' update + upgrade, reinstall with no immediate effect. After system reboot the problem disappeared.

When I opened the .deb again - issue reproduced.

Good luck!

share|improve this answer
Update : the 'fix' did not work twice. When started e.g "software-center --debug gedit" app starts. On click on the 'All Software' icon it crashes. – Didko May 7 '13 at 21:32
Thnx I got some feedback from… and it works perfectly – Morfeos May 7 '13 at 21:53

1) sudo apt-get remove --purge software-center

2) sudo apt-get install software-center

3) sudo software-center &

share|improve this answer
@ Hojat: This is the error that I get when i do the above steps. AttributeError: 'NoneType' object has no attribute 'contains' – Morfeos May 6 '13 at 20:13
it is a bug in software center, so just run sudo apt-get update and sudo apt-get upgrade this should fix this. – Hojat Taheri May 6 '13 at 20:25
Even though I try to update it still shows an error vangjush@vangjush:~$ sudo apt-get update [sudo] password for vangjush: E: Malformed line 57 in source list /etc/apt/sources.list (dist parse) E: The list of sources could not be read. – Morfeos May 6 '13 at 20:30
it seems that you have changed your sources file, please send us this file.. – Hojat Taheri May 6 '13 at 20:42
Unfortunate the context of the file has more than 2 two links and I cannot post it on my question. Can you give me your email and I will send you by mail. – Morfeos May 6 '13 at 20:52

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.