Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I had Ubuntu running on an acer easyStore box. When the power supply got too loud, I decided to move the harddrive to a desktop box. However, when I tried to boot up, the screen tells me to pick a cd drive (even though I set hard drive as the first option in the boot order in the bios settings). I luckily have an Ubuntu cd so I was able to boot into that. One of the options there is to boot from hard disk and that works fine. So how do I get machine to boot from the hard disk?

Potentially useful pieces of info: The desktop was purchased around 2007. The easy store was purchased in 2011. I suspect an issue with the partition table format (MBR vs GPT) but don't know for sure if that's the problem.

Here is the output of gdisk and parted:

robarson@mercenary:~$ sudo gdisk -l /dev/sda
GPT fdisk (gdisk) version 0.8.1

Partition table scan:
  MBR: protective
  BSD: not presen
  APM: not present
  GPT: present

Found valid GPT with protective MBR; using GPT.
Disk /dev/sda: 3907029168 sectors, 1.8 TiB
Logical sector size: 512 bytes
Disk identifier (GUID): 9F77ECBD-E11B-4245-B834-70E449BF4F3E
Partition table holds up to 128 entries
First usable sector is 34, last usable sector is 3907029134
Partitions will be aligned on 2048-sector boundaries
Total free space is 2157 sectors (1.1 MiB)

Number  Start (sector)    End (sector)  Size       Code  Name
   1            2048            4095   1024.0 KiB  EF02 
   2            4096      3901030399   1.8 TiB     0700 
   3      3901030400      3907028991   2.9 GiB     8200 
robarson@mercenary:~$ sudo parted -l
Model: ATA ST32000542AS (scsi)
Disk /dev/sda: 2000GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt

Number  Start   End     Size    File system     Name  Flags
 1      1049kB  2097kB  1049kB                        bios_grub
 2      2097kB  1997GB  1997GB  ext4
 3      1997GB  2000GB  3071MB  linux-swap(v1)


Warning: Unable to open /dev/sr0 read-write (Read-only file system).  /dev/sr0
has been opened read-only.
Error: /dev/sr0: unrecognised disk label
share|improve this question
add comment

1 Answer 1

It's possible that the newer computer was configured to boot in EFI mode rather than in the older BIOS mode, which is probably what the older computer uses. Check your partition table. If you've got a smallish FAT partition at the start that shows in GParted or parted as having its "boot flag" set, or that gdisk shows as having a type code of EF00, then that's an EFI System Partition (ESP). Check it for files. If there's a directory called EFI/ubuntu with a file whose name ends in .efi (such as grub.efi or grubx64.efi), then this supports my hypothesis.

If I'm right, you can fix it by booting the hard disk using the circuitous path you've chosen, creating a small (~1MiB) BIOS Boot Partition, uninstalling the grub-efi package, installing the grub-pc package, and running sudo update-grub. This should set up a BIOS-mode boot loader on the disk. Note, however, that if you subsequently move the disk back to the newer computer, it may fail until you reverse the process and re-install either grub-efi or another EFI-mode boot loader.

share|improve this answer
    
Thank you very, very much for you answer. However, it seems your hypothesis isn't correct. I included the output of gdisk and parted in my question. –  robarson May 7 '13 at 6:03
    
It's conceivable that the problem is analogous, but the other way -- that your older computer that now holds the hard drive uses EFI firmware and is set to boot in EFI mode, whereas the newer one from which the drive was taken was configured to boot in BIOS mode. If so, you might be able to find a firmware setting to change the boot mode from BIOS (aka CSM or legacy) to EFI (aka UEFI). Unfortunately, I can't be more precise than that because these things vary greatly from one computer to another. –  Rod Smith May 7 '13 at 14:55
    
BTW, I've reformatted your pasted gdisk and parted output, since it was almost illegible with the Web site's reformatting. In future, add four spaces to the start of each line of such output to preserve line breaks and use a monospace font. –  Rod Smith May 7 '13 at 14:56
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.