Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have been trying to install cinnamon in my ubuntu 13.04 and when i give

sudo apt-get install cinnamon

I get the error as:

Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies: 
 cinnamon : Depends: libgjs0-libmozjs185-1.0
        Recommends: nemo but it is not going to be installed
        Recommends: cinnamon-screensaver but it is not going to be installed
E: Unable to correct problems, you have held broken packages.
share|improve this question
    
Have you added proper PPA? –  tuxtu May 6 '13 at 14:38
    
yes i have executed a ppa command –  Aswin Murugesh May 6 '13 at 15:24
    
Which PPA did you add? –  Mitch May 6 '13 at 17:17
    
add-apt-repository ppa:gwendal-lebihan-dev/cinnamon-stable –  Aswin Murugesh May 6 '13 at 18:58
    
the ppa has been updated please check now , sudo apt-get update > then > sudo apt-get install cinnamon –  Qasim May 7 '13 at 18:39

3 Answers 3

This happened to me when I had already install Gnome onto ubuntu.

After install Aptitude and using it to install, it gave me the option to downgrade Gnome in order to install Cinnamon. If you do this Cinnamon should install.

$ sudo apt-get install aptitude
$ sudo aptitude install cinnamon
[sudo] password for <USER>: 
The following NEW packages will be installed:
  cinnamon{b} gir1.2-muffin-3.0{a} libmuffin0{a} muffin-common{a} 
0 packages upgraded, 4 newly installed, 0 to remove and 0 not upgraded.
Need to get 2,255 kB of archives. After unpacking 9,065 kB will be used.
The following packages have unmet dependencies:
 cinnamon : Depends: libgjs0-libmozjs185-1.0 which is a virtual package.
            Depends: libmozjs185-1.0 (>= 1.8.5-1.0.0+dfsg) but it is not going to be installed.
The following actions will resolve these dependencies:

     Keep the following packages at their current version:
1)     cinnamon [Not Installed]                           



Accept this solution? [Y/n/q/?] n
The following actions will resolve these dependencies:

     Install the following packages:                                                           
1)     libmozjs185-1.0 [1.8.5-1.0.0+dfsg-4 (raring)]                                           

     Downgrade the following packages:                                                         
2)     gjs [1.36.1+js17-0ubuntu1~raring0 (now, raring) -> 1.34.0-0ubuntu1 (raring)]            
3)     gnome-shell [3.8.1-0ubuntu1~raring1.2 (now, raring) -> 3.6.3.1-0ubuntu6 (raring)]       
4)     gnome-shell-common [3.8.1-0ubuntu1~raring1.2 (now, raring) -> 3.6.3.1-0ubuntu6 (raring)]
5)     gnome-sushi [3.8.0-1~ubuntu13.04.2 (now, raring) -> 3.6.1-0ubuntu1 (raring)]            
6)     libgjs0c [1.36.1+js17-0ubuntu1~raring0 (now, raring) -> 1.34.0-0ubuntu1 (raring)]       



Accept this solution? [Y/n/q/?] y
The following packages will be DOWNGRADED:
  gjs gnome-shell gnome-shell-common gnome-sushi libgjs0c 
The following NEW packages will be installed:
  cinnamon gir1.2-muffin-3.0{a} libmozjs185-1.0{a} libmuffin0{a} muffin-common{a} 
0 packages upgraded, 5 newly installed, 5 downgraded, 0 to remove and 0 not upgraded.
Need to get 4,992 kB of archives. After unpacking 12.4 MB will be used.
Do you want to continue? [Y/n/?] y

you will have to input the 'n' and two 'y's in order to install.

share|improve this answer
    
Worked great; thanks! –  user10962 Oct 5 '13 at 1:49

This is a relatively easy fix, at least an easy one to try! :) It appears you have a broken dependency/package, an easy fix.

Do this:

sudo apt-get clean && sudo apt-get update

It should fix your broken packages error, then you can run the sudo apt-get install cinammon command to install it!

Good Luck!

share|improve this answer
    
no.. I get the same result –  Aswin Murugesh May 7 '13 at 16:32
    
hmm..? I dunno then. –  RPi_Awesomeness May 7 '13 at 17:10
    
Try this command, worth a shot: sudo apt-get install -f –  RPi_Awesomeness May 7 '13 at 17:16
    
this doesnt work too.. –  Aswin Murugesh May 7 '13 at 18:37

The issue seems to be with the pin priority with the PPA. This should fix the issue.

Open the preferences file:

    gksu gedit /etc/apt/preferences

Then add this at the bottom:

    Package: *
    Pin: origin ppa.launchpad.net
    Pin-Priority: 700

Save and close the file and open your terminal to update your packages then install cinnamon.

    sudo apt-get update && sudo apt-get install cinnamon

That should work.

I have switched to Linux Mint 15 for my personal distro choice and this is what I had to do to get the latest release of cinnamon and nemo on my machine.

share|improve this answer
    
In Ubuntu 13.04, there is no such file. But there is /etc/apt/preferences.d folder. Also no such inside it. So where can I find that file ? –  user224082 Nov 9 '13 at 18:06

protected by Community May 8 '13 at 20:32

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.