Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm wondering if any of you can assist with the issues I'm facing with MAAS. I have a working MAAS server that is running DNS and DHCP. I built the MAAS server on 13.04 server. I couldn't get any of the nodes to enlist (show up on the home page of MAAS) with the 13.04 server disc. When I used 12.04, they were enlisted.

However, now that they are enlisted, I cannot get them to commission. They will receive a DHCP response and IP address from the MAAS server and then they will try to boot to an image called pxelinux.cfg/XX-XX-XX-XX-XX-XX-XX where the X's are a MAC address. It just hangs there. I have attached a screenshot. Can anyone assist?

share|improve this question
up vote 1 down vote accepted

After analyzing /var/log/maas/pserv.log, which is the PXE/TFTP boot server log, I noticed that it was complaining that there were no PXE images, or ephemerals, found on the server. The log asked to run maas-import-pxe-files again, even though I had run it multiple times.

2013-05-06 08:02:40-0400 [HTTPPageGetter,client] Stopping factory <HTTPClientFactory: http://localhost/MAAS/api/1.0/pxeconfig/?cluster_uuid=91149761-d1
2013-05-06 08:02:40-0400 [HTTPPageGetter,client] Stopping factory <HTTPClientFactory: http://localhost/MAAS/api/1.0/pxeconfig/?cluster_uuid=91149761-d1
2013-05-06 08:02:40-0400 [HTTPPageGetter,client] Logged OOPS id OOPS-bdc099b3ed2983f2eb94d6096a811915: No exception type: No exception value
2013-05-06 08:02:40-0400 [HTTPPageGetter,client] Logged OOPS id OOPS-ac4bdf5b247f85d2cb53baf0aa4c2183: EphemeralImagesDirectoryNotFound: The directory 
containing the ephemeral images/info is missing (u'/var/lib/maas/ephemeral/raring/ephemeral/amd64').  Make sure to run the script 'maas-import-pxe-file

Notice, that it's looking in a raring directory for ephemerals. This directory doesn't exist.

After running the command again, I noticed that the maas-import-pxe-files only downloads ephemerals for Precise and Quantal, not Raring.

irossi@maasjuju:~$ maas-import-pxe-files 
This utility may only be run as root.
irossi@maasjuju:~$ sudo !!
sudo maas-import-pxe-files 
Downloading to temporary location /tmp/tmp.uTLWpre2Uz.
/tmp/tmp.uTLWpre2Uz ~
2013-05-06 08:14:25 URL: [4965840/4965840] -> "linux" [1]
2013-05-06 08:17:04 URL: [17446386/17446386] -> "initrd.gz" [1]
2013-05-06 08:17:18 URL: [5130968/5130968] -> "linux" [1]
2013-05-06 08:18:28 URL: [18668122/18668122] -> "initrd.gz" [1]
2013-05-06 08:18:45 URL: [5015840/5015840] -> "linux" [1]
2013-05-06 08:19:35 URL: [15977428/15977428] -> "initrd.gz" [1]
2013-05-06 08:20:37 URL: [5171760/5171760] -> "linux" [1]

I checked in the MAAS Server settings page (the gray gear icon) and the default distro for nodes was set to Raring Ringtail 13.04. The nodes were looking for a boot image for Raring that wasn't there. As soon as I changed this setting to Precise 12.04 as the default distro, all of the nodes booted successfully and were commissioned. It's working now, but I'm still not sure if this is user error or a bug. If anyone thinks it's a bug, I'll be glad to file it in Launchpad.

share|improve this answer
I filed a bug: – Ian D. Rossi May 6 '13 at 12:48

Bounce your nodes. I was stuck on this for almost a week. Your servers aren't responding to the "Wake On LAN" or whatever "remote"method you are trying to use to wake up the servers.

After you setup your MAAS controller, you "power-on" your servers. If DHCP/DNS is setup right, the PXE boot and load a version of the OS that is used for "Declaring" the server to the MAAS controller. At that point they show up in your "Nodes" list as declared. You select the server and click on "Accept and Commission", then they stay there, never changing.

For me, this meant that the PXE command to boot to the new "commissioning" OS was IGNORED by my servers. I simply turned them on and voila... about 10 minutes later, they are completely configured and "Ready".

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.