Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

On 13.04 the GWT designer is not working on Eclipse 4.2 and Eclipse 3.7. If I want to switch in the design-mode after executing Workaround 2 from this page, Eclipse crashes and is closing automatically.

I asked this question for 12.10, where it works for my answer on 12.10. I tested both answers from this question and none is working on 13.04.

share|improve this question
up vote 4 down vote accepted

Found a 'clean' workaround [tested on Ubuntu 13.04 (amd64) & Eclipse Kepler]

As it seems, GWT (also SWT) needs an older libwebkitgtk1.0 to run the designer.

So, assuming you already have the 13.04 Ubuntu repository 'libwebkitgtk1.0' (v.1.10.x) installed (as a dependency of Gimp for example), and don't want to mess with it:

1) Download the following (from - BUT DO NOT INSTALL THEM:

  • libwebkitgtk-1.0-0_1.8.3-0ubuntu0.12.04.1_amd64.deb
  • libjavascriptcoregtk-1.0-0_1.8.3-0ubuntu0.12.04.1_amd64.deb

2) Open the 2 files downloaded with Archive manager

3) Create folder $HOME/.eclipse/lib

4) Extract the 'lib' folders contents of the 2 deb files in the folder created

5) Launch eclipse with the following command line (from within the eclipse folder):

LD_LIBRARY_PATH=$HOME/.eclipse/lib ./eclipse

6) Switch to the designer tab - should work.

Basically, what you do is forcing eclipse to first check '$HOME/.eclipse/lib' folder for any needed lib and later the /usr/lib - so you place there the older libs and picks them instead of the system installed ones (and the system is still clean/untouched)

(Just a notice - this is not a fix - its a workaround)

share|improve this answer

I also had a problem like that, Eclipse just crashed suddenly. I upgraded to 4.3M7 and now it works. here's the link:

You might have to download the addons allover again.

share|improve this answer
4.3M7 did not solved the problem. After clicking to switch in the designer mode, Eclipse crashes. – Marian Lux May 6 '13 at 16:35

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.