Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am completely new to Linux and Ubuntu. But after taking a lot of time and pain..I installed Ubuntu Server edition onto my server, got the GUI installed.

Now when I press Alt+F2, I get the "run application" window. But when ever I enter gnome-terminal it gives me this error message "could not open location file:///home/username/gnome-terminal"

I dont know why it is giving this. Can anyone help me with this??

thanks in advance.

share|improve this question

migrated from stackoverflow.com Mar 5 '11 at 17:01

This question came from our site for professional and enthusiast programmers.

closed as too localized by jrg, Jorge Castro, jokerdino, Bruno Pereira, Takkat Jan 26 '12 at 19:58

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
This should go to askubuntu.com –  Ocaso Protal Mar 5 '11 at 12:24
    
Try xterm, that opens a terminal window. No clue for gnome-terminal though. –  iarwain01 Mar 5 '11 at 12:35
    
@yash On Ubuntu desktop edition, gnome-terminal should be installed by default. I suspect the problem is the way you've converted server to support GUI apps. Can you tell us what steps you took (even approximately) to get GUI support? –  belacqua Mar 5 '11 at 22:20
    
This question appears to be abandoned and unanswered, could you perhaps add more detail to your question? If you are experiencing a similar issue please ask a new question with details pertaining to your problem. If you feel this question is not abandoned, then please flag explaining that (as well as editing your question with any details you have). –  jrg Jan 26 '12 at 2:17

2 Answers 2

That's strange. With debian, it works fine… Did you try to give the full path to the gnome-terminal executable (i.e. /usr/bin/gnome-terminal)? If it doesn't work, Alt+F2 call seems to be broken.

share|improve this answer
1  
I don't have the Gnome version installed to verify, but I can imagine this happening if gnome-terminal isn't installed or in $PATH: first it does a PATH search, then falls back to trying the current directory, then reports the error based on that last attempt. –  geekosaur Mar 5 '11 at 12:46
    
Try whereis: renaud@daneel:~$ whereis gnome-terminal and if you get gnome-terminal: with nothing after then gnome-terminal is definitely not installed. –  Renaud Mar 5 '11 at 12:56

I would recommend using Gnome-Do instead of the Alt-F2. It's much more powerful.

share|improve this answer