Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Why does my ubuntu make a WiFi connection ONLY when I disable the security settings of the router?

I have a 3-computer network, 2 of which connect just fine (with the router's security settings enabled). The other two are Win XP PCs. The ubuntu also connected just fine; and then for reasons unknown to me, stopped connecting!

My Belkin router:

  • Security mode/authentication: WPA-WPA2 (Personal PSK) / WPA-PSK +WPA2-PSK
  • Wireless Channel: Auto
  • Wireless Mode: g and b
  • Protected Mode: on
  • 802.11e QoS: on
  • Encryption Technique: TKIP + AES
  • Wi-Fi Protected Setup: on

Will either of these pieces of info help you to help me?

  • Network Controller: Broadcom Corp BCM4313 802.11b/g/n wireless LAN controller
  • Ethernet controller: Atheros Comm Inc. AR8152 v1.1 Fast Ethernet (rev c1)

Any advise, suggestions, solutions will be greatly appreciated!
Thank you for looking.

BTW, here is the link for the text from my Ubuntu, after entering a: “sudo lshw -c network http://sites.google.com/site/stufff2share/brlu

share|improve this question
    
Try deleting the network, then connecting to it again and putting the password in as you normally would. That might work. By security setting, do you mean wireless password/encryption or WPS? –  Vreality May 6 '13 at 2:42
    
I have tried that, but it does nothing. Security = the router's WPA password and the Protected Mode: off, and the Wi-Fi Protected Setup: off –  southy May 6 '13 at 2:45
    
Hmmmm, I'm not sure. Honestly, I'm running into a similar problem myself. –  Vreality May 6 '13 at 2:47
    
Troubleshooting WiFi is easier when you reduce as many variables. Are you able to pick a 802.11G or B instead of dual mode, I've seen it cause problems in Windows and and LINUX. The WiFiprotected setup I doubt is causing your connection problem but if you aren't using it, it s more of a security weakness than benefit if you don't need it, its worth turning off when you get past the cheerleader vendor sites advocating it: zdnet.com/blog/networking/wi-fi-protected-setup-is-busted/1808 Sometimes, IPv6 can be a culprit but less and less frequently. If you're other systems are working, I –  Karen3819x4 May 6 '13 at 2:50
    
I suspect you are using the incorrect driver for your wireless. Please run from a terminal: lspci -nn -d 14e4: Is your device 14e4:4727? There are two drivers for this device and one is, as you've seen, wrong. Let's verify which driver is being used: lsmod | grep -e wl -e brcm Please edit your question to add the details and we'll proceed. –  chili555 May 6 '13 at 12:46
show 3 more comments

3 Answers

Troubleshooting WiFi is easier when you reduce as many variables.

Are you able to pick a 802.11G or B instead of dual mode, I've seen it cause problems in Windows and and LINUX. The WiFiprotected setup I doubt is causing your connection problem but if you aren't using it, it s more of a security weakness than benefit if you don't need it, its worth turning off when you get past the cheerleader vendor sites advocating it:

http://www.zdnet.com/blog/networking/wi-fi-protected-setup-is-busted/1808

Sometimes, IPv6 can be a culprit but less and less frequently.

If you're other systems are working, I'm less keen on blaming the router if it works with other systems and would focus on the problematic box.

If you need to indict the router, TEMPORARILY downgrading the security to WEP before smoking it do default naked config is my strong recommendation,

share|improve this answer
    
Well, both G only and B only did nothing. "I'm less keen on blaming the router..." "focus on the problematic box" Not sure which "box" you're referring to? "If you need to indict the router, TEMPORARILY downgrading the security to WEP before smoking it do default naked config" -- Do you mean before I throw the router in the trash (smoking it) that I should set the router with no security settings (its default)? I do know that I can connect when there's no password--if that's its default; but I don't like the idea of an open router. –  southy May 6 '13 at 3:08
add comment

I've noticed almost consistent instability with WPA2 and Ubuntu's Network Manager. When it presents it usually shows as the machine being unable to obtain an IP, or maintains a poor connection. My advice is to switch to WICD client if you want to keep using WPA2, or use a more basic encryption on your router, like WEP.

Uninstalling Network Manager:

sudo apt-get remove NetworkManager

Installing Wicd

sudo apt-get install wicd-client

This has fixed many, many WPA2 connections for me.

share|improve this answer
    
Sorry, I don't know what WICD is? Also, for now, I've removed the password from my router and now my Ubuntu connects and I can get on-line. Interestingly, what this has also "fixed", is that my faxing software (MightyFax) will now send faxes. Up to this point, it would only receive faxes. So it seems as though there's something going on with the password aspect of the router because now that it's free of having a WPA password, Ubuntu connects (and my faxes get sent)! BTW, I did try WEP on the router, but Ubuntu would not connect (nor would faxes get sent.) –  southy May 8 '13 at 3:12
    
Oh, it's just a wireless manager - the program that displays wifi connections in your system bar and manages connections. The default one in Ubuntu is called Network Manager, WICD is just an alternative program that I've noticed performs a bit better with WPA2. Also I would recommend that you try and enable some form of security on your home wifi, even if it is basic. Can't be too safe these days... –  user89599 May 9 '13 at 4:08
    
Thanks for the WICD explanation, and the advise! I'm still working on this issue. I don't like the disabled security aspect of the router either; but it seems to be the only way Ubuntu will connect. I'll see what happens after I try the WICD –  southy May 10 '13 at 3:57
    
Well, I followed your WICD instructions; but nothing changed--Unbuntu is not connecting to the router! I'm not sure what, if anything, has actually changed in doing the WICD--the Ubuntu screens look exactly the same--System Settings/Network/Wireless. Still, the only way to get Ubuntu to connect to the router is to remove the router's password (any kind of password). Assuming my install of WICD worked, Where should I see it? –  southy May 11 '13 at 1:08
    
Well, I found that neither NetworkManager nor WICD is on my Ubuntu--to be more precise, they're "not found". I'm guessing that the WICD install failure is because my Ubuntu will not connect online? NEW problem: now my Ubuntu will not connect to the router at all, despite the fact that it (the router) has NO security features enabled. I'm guessing this is because of the missing NetworkManager? Trouble is, as I've noted throughout this thread, I can't get online (to reinstall NetworkManager, or anything else for that matter). So here I am stuck between a rock and a hardplace! –  southy May 16 '13 at 16:28
add comment

I have a similar setup a home network with multiple wireless devices and I'm having trouble with my work laptop connecting to my home network a Linksys WRT160N running WPA2. I can see the wireless network but can't connect to it. But I can from the laptop when it's running Windows 8.

I've done a lot of searching around the topic and it definitely seems to be a driver issue for the BCM4313 (in my case). Lots of the proposed solutions seem to involve old or different drivers and seem complex, however I just stumbled upon a simple looking (possible) solution which I'll give a try when I get home: http://eikon.morogen.com/2013/04/samsung-nc110-wifi-fix-for-ubuntu-1304.html

Such a shame I have to fight to get my wireless working on a fairly new and mainstream laptop in the most recent version of Ubuntu. Hope it works next time around!

share|improve this answer
    
This worked for me. Using Ubuntu 13.04 64bit on a Toshiba Satellite R630-13T, dual booting with Windows 8. I had to turn my mobile into a wi-fi hotspot, connect to that network and run the apt-get commands. Hope this helps anyone else stuck. –  Craig May 14 '13 at 21:27
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.