Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've installed Ubuntu 13.04 on my laptop HP 6720s with video card Intel 965 chipset Intel gma x3100. After the boot the classic purple screen appear and before the login page the screen become black and the pc remain freezed.

For all last versions of Ubuntu the following commands repaired the situation:

Recovery mode with network:

apt-get remove --purge nvidia*
rm /etc/X11/xorg.conf
apt-get update
apt-get

Recovery mode again:

apt-get install nvidia-current
nvidia-xconfig
reboot

But for the 13.04 version it doesn't work.

Thank you in advance!

share|improve this question
    
@zendessert This option you described here is all greyed out for Additional Drivers and says "No proprietary drivers are in use." –  user94959 Mar 13 at 6:06

2 Answers 2

Hit Ctrl + Alt + F1 to reach the first virtual console. Log in there, then follow the instructions.

To get all the relevant stuff, including the kernel sources and kernel headers run next command

sudo apt-get install build-essential linux-source linux-headers

If the package linux-headers is not available, try running the command by specifying the exact version of the headers with:

sudo apt-get install linux-headers-`uname -r`

Next, install the current Nvidia driver:

sudo apt-get install nvidia-current

Once the installation completes successfully, check if the Nvidia driver is loaded:

sudo /sbin/lsmod | grep nvidia

If it's not, you will need to manually insert into memory. First, make sure all kernel module dependencies are satisfied and resolved:

sudo depmod -a

Then, load the driver:

sudo modprobe nvidia_current

This should succeed and the lsmod command should show it's loaded, but the usage count will probably be 0, because nothing will be using it yet. You will need to restart the graphics environment to actually benefit from the driver:

sudo /etc/init.d/lightdm restart

This will restart the graphics environment, you will see the Nvidia splash, and you will load into a desktop that has the Nvidia driver running, and all that. Your problem is now resolved.

enter image description here enter image description here

Source: http://www.dedoimedo.com/computers/ubuntu-quetzal-nvidia.html (even if the specified source is related to Ubuntu 12.10, I test this method and is working perfectly on Ubuntu 13.04).

share|improve this answer
1  
Hi, thank you very much for your time! It works until the command sudo modprobe nvidia_current And it says: FATAL: Module nvidia_current not found. The following command lightdm restart feezes the pc. A restart of the laptop provide again a black screen. –  user155915 May 6 '13 at 18:33
    
Do this in tty1 (first virtual console), Ctrl + Alt + F1 –  Radu Rădeanu May 6 '13 at 21:27
1  
Yes, I'm in tty1 mode, try to reinstall from cd. Thank you a lot! –  user155915 May 6 '13 at 23:47
    
Solved only after a fresh install. Thank you a lot. –  user155915 May 7 '13 at 23:28
    
This just ripped me a new one. I did it in the gui like an idiot and now I can't get my desktop back. I can open windows with hotkeys, but other than that she's cashed. –  notbad.jpeg Jun 28 '13 at 22:14

It is easier to follow this approach:

  1. Click the gear icon in the top right corner of the screen.
  2. Click "System settings..."
  3. Click "Software & Updates" in the "System" category.
  4. Click on the "Additional Drivers" tab and select the proprietary driver.
  5. Click "Apply Changes".

Reboot, job done!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.