Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I today got stuck while trying to install/set up my USB-WLAN Adapter. It's a DWA-111 USB-Stick (Rev. A1) and my machine is currently running Ubuntu 12.04 LTS. (As far as I know it's got a RT73 chipset by ralink, but I am not completely sure.) So much for this.

The Adapter runs perfectly using a machine with Win7 installed but it does absolutely nothing when I plug it at my Ubuntu 12.04 machine. iwconfig and ifconfig show nothing, as well as the device is not listed when executing lsusb. So it seems it's entirely unknown to my computer.

Here's some output of lsusb, now showing the D-LINK device (as already described below in comments I just noticed the device is appearing and disappearing every now and then):

Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 004: ID 07cc:0301 Carry Computer Eng., Co., Ltd 6-in-1 Card Reader
Bus 002 Device 009: ID 046d:c223 Logitech, Inc. Keyboard / USB Hub
Bus 002 Device 003: ID 1e7d:2ced Logitech Mouse
Bus 002 Device 010: ID 046d:c226 Logitech, Inc. Keyboard
Bus 002 Device 011: ID 046d:c227 Logitech, Inc. Keyboard
Bus 001 Device 039: ID 07d1:3c06 D-Link System 

Information on an error in /var/log/syslog

May  5 18:34:39 COMPUTER kernel: [ 7738.978659] phy1 -> rt73usb_init_eeprom: Error - Invalid RT chipset detected.
May  5 18:34:39 COMPUTER kernel: [ 7738.978662] phy1 -> rt2x00lib_probe_dev: Error - Failed to allocate device.
May  5 18:34:39 COMPUTER kernel: [ 7738.978763] usb 1-9: USB disconnect, device number 12
May  5 18:34:39 COMPUTER mtp-probe: bus: 1, device: 12 was not an MTP device
May  5 18:34:39 COMPUTER kernel: [ 7739.092048] usb 1-9: new high-speed USB device number 13 using ehci_hcd
May  5 18:34:40 COMPUTER kernel: [ 7739.258536] usb 1-9: too many configurations: 60, using maximum allowed: 8
May  5 18:34:40 COMPUTER mtp-probe: checking bus 1, device 13: "/sys/devices/pci0000:00/0000:00:13.5/usb1/1-9"
May  5 18:34:40 COMPUTER kernel: [ 7739.796047] usb 1-9: reset high-speed USB device number 13 using ehci_hcd
May  5 18:34:40 COMPUTER kernel: [ 7739.962505] usb 1-9: device firmware changed
May  5 18:34:40 COMPUTER kernel: [ 7739.962547] phy2 -> rt2x00usb_vendor_request: Error - Vendor Request 0x09 failed for offset 0x0000 with error -19.

This error messages just keep repeating over and over.

Any ideas how do I get the device installed and running? And additionally any idea about the lsusb behaviour? Thank you!

share|improve this question
    
lsusb has to list it anyway, try lsusb -v. Sometimes the vendor name differs from that is shown in windows. Check the IDs. –  grimpitch May 5 '13 at 18:13
    
OK, just experienced a very weird behaviour of lsusb I just ran it several times and the 4th time I executed it, it showed the D-LINK device. But then, running lsusb a 5th time is disappeared again. (I'll add the output of lsusb above.) –  ch.bailey May 5 '13 at 18:40
1  
The disappearing device can be a power management thing, but still, it shouldn't disappear from the device list completely. Look for traces about that in the /var/log/syslog, /var/log/dmesg, and /var/log/pm-powersave.log. The kernel driver for this device is the rt73usb module, load it with sudo modprobe rt73usb. Also make sure that the linux-firmware package is installed. –  grimpitch May 5 '13 at 19:49
    
Thank you @grimpitch . I found some information about the error in /var/log/syslog. I will soon add the output above as well. –  ch.bailey May 5 '13 at 21:42
1  
I suspect the device is failing. –  chili555 May 5 '13 at 22:28
show 1 more comment

1 Answer

USB ID: 07d1:3c06

D-Link Systems DWA-111 802.11bg Wireless Adapter - [Ralink RT2571W]

Source: Debian.org > Ralink RT2501USB/RT2571W (RT73) devices


Possible solutions:

(1.) How do I get a Ralink RT3060 wireless card working? (for 12.04)

Option 1. Try installing the latest compat-wireless backports package and see if it works ..

Option 2. Build and install Ralink's own drivers ..

(2.) Load the device-firmware drivers (to load firmware to device)

sudo apt-get install linux-firmware-nonfree

share|improve this answer
    
well, I tried all these steps but none works. Which also would lead to the conclusion that the device is broken - but as I tested it one more time on a Windows 7 machine and it worked I can say, that it's fully functional there. Just keeps disappearing again and again on my Ubuntu machine. –  ch.bailey Jun 5 '13 at 18:48
    
Look at other RaLink issues on this forum. Click on that tag (below your question). –  david6 Jun 6 '13 at 8:38
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.