Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've had made a huge mistake by wiping out every VLC folder from Ubuntu 12.04. I tried to reinstall it, but it doesn't work.
I tried installing it by command line and it seems to work: however, when I run the vlc command, it says VLC is not installed.
If I try to install it again, it tells me VLC is already at the latest version. Now I can't run VLC any more and can't figure how to fix it. Thanks in advance!

I ran these:

sudo apt-get remove -f --purge vlc vlc-data vlc-nox vlc-plugin-notify vlc-plugin-pulse

And then these:

sudo apt-get install -f vlc vlc-data vlc-nox vlc-plugin-notify vlc-plugin-pulse

Apparently everything gets back to normal. Even the icons got back. Now I finally am able to run vlc on the terminal and get some response. Unfortunatey I still am not able to make it run properly, VLC does not open by any chance. This pops up:

VLC media player 2.0.5 Twoflower (revision 2.0.5-0-g1661b7d) 

The remote control interface was started. Type 'help' for help.

However, not a single window opens.

share|improve this question
    
Have you tried running sudo apt-get autoremove vlc? –  Frederik Popp May 4 '13 at 20:48
    
Yes I have. It is removed and I am able to install it again but it doesn't start anyway. The vlc is not installed message keeps showing and vlc keeps not running. –  daureo May 4 '13 at 21:07
    
Try checking the official website for VLC. Here's a link: videolan.org/vlc –  Frederik Popp May 4 '13 at 21:22

3 Answers 3

up vote 3 down vote accepted

Delete the VLC profile.

  1. Go to Home folder
  2. Press CTRL & H (To show hidden files)
  3. Open the folder .config
  4. Right click on vlc folder and delete
  5. Restart VLC and see how it works.

Deleting the profile folder of VLC makes it work as when you first installed it.

share|improve this answer
    
Thank you so much! –  daureo May 4 '13 at 22:02

I have the same problem with deleting all folders that find in my Ubuntu 13.10 x86_64. Following the steps above, installing it and now it is running well. I saw that there is a mistake in the following line $sudo apt-get remove -f --purge vlc vlc-data vlc-nox vlc-plugin-notigy vlc-plugin-pulse

(vlc-plugin-notigy) must be vlc-plugin-notify

$sudo apt-get remove -f --purge vlc vlc-data vlc-nox vlc-plugin-notify vlc-plugin-pulse

And then, ran these

$sudo apt-get install -f vlc vlc-data vlc-nox vlc-plugin-notigy vlc-plugin-pulse browser-plugin-vlc

I am using firefox browser, and need the browser plugging, last one is sugested in the vlc website.

share|improve this answer
    
It was most likely a typo. –  Braiam Feb 9 at 13:25

Interesting issue you have there... Have you tried

sudo apt-get remove vlc --purge
sudo apt-get install vlc
share|improve this answer
    
I've already tried and yet no positive response. –  daureo May 4 '13 at 21:08

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.