Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Okay, so right now, I have installed both nvidia drivers and bumblebee and am getting all the necessary functions working - battery conservation, higher fps etc....

But when I try
lsmod | grep nvidia*
or
lsmod | grep nouveau
or
lsmod | grep bumblebee

I am not getting any working modules of these types.

Is something missing, because my synaptics shows the drivers installed and am pretty much sure the system is working fine. Also would an kernel upgrade break my system? Or is there someway to do it without breaking it?

Hey guys, is this even possible?

share|improve this question
    
Any help on this would be appreciated as I would be updating the kernel soon, and would like to know whats where in the sytem before attempting that –  charlie May 7 '13 at 10:48
    
I use bumblebee to, but lsmod | grep nouveau works for me. I have noticed in the other post that you have instaled nvidia drivers then bumblebee. I don't do it like that. I just install bumblebee witch isntals some nvidia drivers from their repository sudo add-apt-repository ppa:bumblebee/stable sudo apt-get update sudo apt-get install bumblebee bumblebee-nvidia –  Rat2000 May 27 '13 at 19:13
    
@Rat2000 thanks!..unfortunately from many nvidia drivers I tried, 319 is the only one that worked for me.. hence using them. –  charlie May 28 '13 at 3:12

1 Answer 1

I haven't managed to get to run bumblebee yet, but I'm also seeing no nouveau entries in the output of dmesg until trying to run something that actually accesses the discrete graphics adapter with optirun:

optirun glxgears

Then you should be getting nouveau or nvidia entries in your logs, and also in the output of lsmod.

By default, only the integrated graphics adapter is used, most probably with a different driver.

share|improve this answer
    
Hey you are right! running something with optirun did make the nvidia module visible. But no bumblebee. Does that mean that optimus technology is not being used in my system? –  charlie Jun 18 '13 at 19:06
    
@charlie: Try ps -elf | grep bumblebeed, you should see two entries -- one for the grep, the other for the Bumblebee daemon. –  krlmlr Jun 19 '13 at 14:28
    
Yes I do get two lines. What do they mean? What does the command do? –  charlie Jun 19 '13 at 15:55
1  
@charlie: ps -elf lists pretty much all processes, I don't remember exactly what the individual switches mean, but you can ask man ps. grep searches in this list and returns the matching lines, which will of course also include the grep process itself. The pipe | asks the grep process to use the output of the ps process as its input. –  krlmlr Jun 19 '13 at 20:50

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.