Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Well I'm running ubuntu on arm7 and had xrdp running nicely with tightvncserver, lxfe, then it stopped working, reporting a login error. Looking at the log for xrdp it seems to be fireing up Xvnc ok and logging in ok, then nothing.... the logs are exceptionally poor so I don't know exactly what it's doing at all.

Anyhow, if I run Xvnc in the terminal and edit /etc/rdp/rdp.ini to work on the correct port all is fine (except there's no windows manage or desktop environment variable setup, but that's more down to how Xvnc works more than anyting).. i still get a stock X desktop and can run xfe ok for some reason, it dosn't complan that it can't find the desktop like other X apps do. No password needed to do this.

I can also run vncserver, give it a password, edit /etc/rdp/rdp.ini and it works fine so long as I put the same password in when xrdp fires up.

both also run just fine with no parameters, so it seems the defaults are ok too.

So it seems like there's some problem with xrdp-sesman hooking up to Xvnc (tightvncserver), but I have no idea what that is...

any clues on how to diagnose this further or a possible solution to the problem?

share|improve this question
    
Well I may possibly have discovered one part of the problem, which is symantic and possibly dpkg isn't even putting in default configuration files e.g. I just installed cups and found some conf files that didn't get setup, though changing my window manager seemed to change the config files, well possibly... so it may be an issue of some config file somewhere or other not being upto data due to dpkg... I don't have much installed so I may just do a clean install... runnnung vncsever in the terminal is only a minor issue for me anyhow. –  user2330377 May 4 '13 at 22:38
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.