Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed lampp a couple of weeks ago. Everything works fine when it comes to html files, but when I try to open a php file, the browser asks me where to download it. :/

I tried with my php files, I also made a test.php wich calls phpinfo() with no results. localhost/xampp and localhost/ also asks me for download location.

I added the following line to httpd.conf: AddType application/x-httpd-php .php .php3 .php4 .php5

But still no results. What could be wrong? Thanks for your help!

share|improve this question
    
How did you install it? –  guntbert May 4 '13 at 21:12
    
I downloaded the tar file, and uncompressed it on /opt –  ezabaw May 7 '13 at 16:23
add comment

1 Answer 1

up vote -1 down vote accepted

LAMPP will not Works perfectly on Ubuntu.

You should try

sudo apt-get install apache2 php5 apache2-php

and then you have a PHP enabled server!

share|improve this answer
    
sudo apt-get install apache2 php5 did the trick :) however apt-get didn't find apache2-php –  ezabaw May 7 '13 at 16:33
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.